Exercise 5. HEC-HMS Modeling using data from GIS Data Services
Extension
GIS in Water Resources, Fall 2015
Prepared by David Tarboton, Cyndi Castro, Gonzalo Espinoza and David
Maidment

Purpose
The purpose of this extension to exercise 5 is to develop and run your own HEC-HMS model for Onion
Creek.

1. Preparation

This extension assumes you have already done Exercise 5 at
http://www.caee.utexas.edu/prof/maidment/giswr2015/Ex5/Ex52015.pdf and have an Ex5.mxd map
document and Onion_HEC.gdb from having run AutoHMS -> GetData. Make sure that ArcMap has been
saved, closed and re-opened before proceeding because the Run AutoHMS tool sometimes gives errors

if this has not been done.

Onion_HEC.gdb is in http://www.neng.usu.edu/cee/faculty/dtarb/giswr/2015/Ex5Data.zip for students
who are unable to use the ArcGIS services through an organizational account.

2. Prepare HEC-HMS basin file
Use this data downloaded in Exercise 5 in AutoHMS to create a .BASIN file, which is an ASCII text file
used by HEC-HMS to populate the software with hydrologic elements and their respective attributes (i.e.
downstream connectivity, loss parameters, routing parameters, basin area).

1) Open ArcMap and locate the Run AutoHMS tool in the AutoHMS Tool.tbx toolbox. This should

be in Ex5tools in the project folder where you initially unzipped

http://www.neng.usu.edu/cee/faculty/dtarb/giswr/2015/Ex5tools.zip

2) Select the Run AutoHMS script from the toolbox.

= & AutoHMS Tool.tbx
5 Get Data
Z Run AutoHMS

3) Input the geodatabase created with the Get Data script (Onion+HEC.gdb).
4) Select an output directory where the HEC-HMS .BASIN file will be saved.
5) Input a name for the .BASIN file (i.e. OnionCreek).

6) Select OK. This process should take approximately 1 minute to complete.


http://www.caee.utexas.edu/prof/maidment/giswr2015/Ex5/Ex52015.pdf
http://www.neng.usu.edu/cee/faculty/dtarb/giswr/2015/Ex5Data.zip
http://www.neng.usu.edu/cee/faculty/dtarb/giswr/2015/Ex5tools.zip

Input Geodatabase Run AutoHMS
Ci\giswr 20 15\Ex5YOnion_HEC.gdb
Qutput Directory
C:\giswr 2015\Ex5\HEC

Preprocessing tool for HEC-HMS
moadel using NHDPlusV2.1 and
ArcGIS Living Atlas server data input.
Basin File Mame
OnionCreek

-

| ok || cencel |[Envionments...|| <<ridetelp | | ToolHep |

Note that this function sometimes gives errors if the layers it is working on are open in ArcMap, so if you
get an error, remove all layers from Onion_HEC.gdb from your map, save, close and reopen and try
again.

You should now have much more data in Onion_HEC.gdb and the file OnionCreek.BASIN that specifies
the basin model for HEC-HMS.
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The basin file OnionCreek.BASIN is a text file that you can open in a text editor (e.g. Wordpad) to view
the input properties computed from the GIS information. You should not edit information in this file
unless you really know what you are doing.



Mame Date maodified Type Size

|Z] OnionCreek.BASIN 10/26/201510:54 ...  BASIN File 29 KB

Easin: CnionCreek
Last Modified Date: 26 October 2015
Last Modified Time: 22:54:16
Version 3.5
Filepath Separator: %
Unit Sy=tem: English
Mizs=ing Flow To Zero: No
Enable Flow Ratio: Mo
21low Blending: No
Compute Local Flow &t Junctions: Mo

Enable Sediment Routing: No

Enable Quality Routing: No
End:

Junction: Junction—J2
Canva=s ¥X: —-1e67820.25385:2
Canvas Y: —-1141769.56592
Downstream: Flowline—2
End:

Junction: Junction—JS
Canvas ¥: —-1552232.555437
Canva=s Y: —-1145511.5417
Downstream: Flowline-10
End:

To turn in: Open the attribute table for the Subbasin feature class in Onion_HEC.gdb. For the largest
subbasin (Note that Subbasin in HEC corresponds to Catchments we delineated earlier) report the slope
and percentage imperviousness (Imp column). Compare these values to the values you calculated above
using zonal statistics.

3. Prepare other inputs and run HEC-HMS
Start HEC-HMS from the start button or desktop icon.
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Initially you get this blank screen
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From the File menu (or icon) select New and set a name, location and U.S. Customary units and click

Create.




Mame: | CnionCreek

Description: |Onion Creek at Highway 183

Location: |C:YUsers\dtarb\Ex5\HEC

Default Unit System: |

[ Create H Cancel ]

A new folder with the Name given will be created in the location you designate. Click File -> Import ->
Basin Model and select the OnionCreek.BASIN file produced by ArcGIS.

A HEC-HMS 4.1 [C\giswr2015\
File | Edit View Compenents Parameters Compute Resull
Mew... CirleN (o @ &, b I 5 &
Open.. Ctrl+0 |
Import k Simulation Run...
Save Ctrl+5 Basin Model...
Save As... Meteorologic Maodel...
Delete... Ctrl+D Control Specifications...
Rename.. HEC-1 File...

In the components panel on the left you should see OnionCreek under Basin Models. Click on this to see
the Basin Model window. Note that a Basin, in HEC Jargon has been created for each catchment in the
Catchments polygon provided to the HEC-HMS data preparation scripts. This is a detailed distributed
representation of the Onion Creek watershed that would have been tedious and error prone to set up
by hand. Pretty cool!
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Catchment-2

&) Basin Model |

Name: OnionCreek

Description: E
Grid Cell File:
Local Flow: | No -
Flow Ratios: :No -
Replace Missing: :No v:
Unit System: |U.5. Customary - I8
Sediment: :No - 4 b
Water Quality: |No =
. . MNOTE 10008: ngin opening. projec.t 'Onion.Creek' in t?hre.ctory 'C:‘gisu\:rzolS\EXS\J-IEC\,Onion.Creek' at 11'mz=T 260ct2015, 23:08:38.
MOTE 1001%: Finished opening project "OnionCreek” in directory "C:\giswr 2015\Ex5\HEC\OnionCreek” at time 260ct2015, 23:08:38.

Note that you may need to select View -> Maximum Extents and adjust the Element buffer to see the
most downstream elements in the Basin Model View

-
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22 Maximum Extents [OnionCreek] ﬁ

Method: :3_.Ir1iur1 Of All Elements; v:

Manual view extents
Minimum Morthing:  |-1153175. 2455
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Set values from current view: Set

Element buffer

Percint (%) | 155

[ oK ][ Cancel ]
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In addition to basin properties, HEC needs meteorological information to determine a design storm. The
City of Austin provides precipitation depth-duration frequency information at



https://www.municode.com/library/tx/austin/codes/drainage criteria_manual?nodeld=APXBDERAFRIN
RAFRAUTRCOTE

The values circled are for a 100 year storm

Table 1. Depth-duration frequency of precipitation for Austin and Travis County, Texas

[Note: Values in table derived from Asquith (1998). The location used to define the parameters of the precipitation distribution was Tom Miller Dam on
the Colorado River near the center of the Austin area located at latitude 30°17'39" and longitude 97°47'12". min., minutes; hr, hours; in., inches]

Annual Recurrence | Precipitation depth and duration

non-exceedance | interval

probability (years) 15min | 30min | 1 hr 2hr 3hr 6 hr 12 hr 1 day 2 day 3 day 5 day 7 day
(percent) (in) (in) (in) (in) (in) (in) (in) (in) (in) (in) (in) (in)
0.500 2 0.98 1.32 1.72 2.16 232 267 3.06 3.44 3.81 4.04 4.30 457
.600 25 1.05 1.42 1.86 2.35 2.53 2.91 3.33 3.84 428 451 4.81 5.08
.700 3.33 1.14 1.54 2.04 2.58 2.79 3.19 3.64 4.33 484 5.08 5.43 5.7C
.800 5 1.26 1.71 2.28 2.89 3.13 3.56 4.07 4,99 5.60 5.85 6.26 6.52 -
.900 10 1.47 1.98 2.68 3.42 3.7 4.21 4.81 6.10 6.88 7.4 7.65 7.91
.960 25 1.76 2.36 3.28 4.20 4,55 5.14 5.90 7.64 8.63 8.91 9.53 9.7¢
.980 50 2.01 2.68 3.79 4.88 5.28 5.94 6.86 8.87 10.0 10.3 11.0 11.2
.990 @) 2.29 3.04 4.37 5.66 6.1 6.85 7.96 10.2 115 1.8 12.6 127
.996 250 2.73 3.57 5.26 6.86 7.38 8.24 9.67 12.0 13.6 13.9 14.7 14.8
.998 500 3.1 4.02 6.06 7.94 8.51 9.47 11.2 13.5 15.2 15.6 16.5 16.5 |
< I} | r i

In HEC-HMS click on Components -> Meteorologic Model Manager and Click New. Accept the default
name and click Create.


https://www.municode.com/library/tx/austin/codes/drainage_criteria_manual?nodeId=APXBDERAFRINRAFRAUTRCOTE
https://www.municode.com/library/tx/austin/codes/drainage_criteria_manual?nodeId=APXBDERAFRINRAFRAUTRCOTE
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Name : | JEE]

Description : E
Components | Compute | R
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[ Name: Logan_NHD
[ Description:

L Grid Cell File:

| Local Flow: |No

Flow Ratios: |No

||| Replace Missing: |No
Unit System: |U.5. Customary -

i HEC-HMS 4.1 [C:\Usershdtarb\ExS\HEC\Logan_NHD'\Logan_N HD.hmsl- 1
File Edit View |Components| Parameters Compute Results Tools Help
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Logan NHD E
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| Sediment: |No . || |MOTE 10008: Begin opening project "Logan NHD" in directory "C: YUsers\dtarb\Ex5\HEC Logan_NHD" at time 230ct2015, 07:28:20.
MOTE 1001%: Finished opening project "Logan NHD" in directory "C:\Users\dtarb\Ex5\HEC Logan_NHD™ at time 230ct2015, 07:25:20,
Water Quality: |No w || [MOTE 10179: Opened basin model "Logan_NHD" at time 230ct2015, 07:30:43,
| 4 L 3

Close the Meteorologic Model Manager using the red X. Your components listing now includes a

Meteorologic Model. Click on Met-1, and then in the panel for setting properties at the bottom left

switch from a Specified Hyetograph to Frequency Storm.
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Click Yes to the warning about losing data. We have not entered any data for a specific Hyetograph that
we would be in danger of losing. Note that above the detail under the Met-1 Meteorology Model
changes to Frequency Storm.

Click on Basins next to the Meteorology Model tab and under Include Subbasins, toggle from No to Yes.



Companents | Compute I F'-ESU|’ES|

t,;ié Meteorology Mode Options

Met Name: Met 1

[ Basin Model | Indude Subbasins
OnionCreek ‘No = J

Mo

You should then see that in the table of components each catchment is listed below the Frequency
storm indicating the association of the Frequency Storm with each Catchment.

Click on Frequency Storm so that its parameters are displayed in the bottom left panel. Change the
settings indicated. Note that what is displayed in blue is unsaved. If you click save in the top bar the
data will be saved to the project file and display switch to black. You should do this periodically.
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Intensity Duratidh: | 15 Minutes

Storm Duratign: -6 Haurs
Intensity Position:

Storm Area (MI2Z)
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Curve: | Uniform For All Subbasins -
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Next click Components -> Control Specifications Manager and New and Create, leaving the default name
Control-1.
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In the components panel on the left collapse Meteorologic models and expand Control Specifications
and click on Control-1. Set start and end date and times as indicated. These are arbitrary. We are

looking for 2 days of simulation and a 6 hour storm.

12



, Logan MHD
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Now we are ready to set up a model run. Click Compute -> Simulation Run Manager and select New
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Accept the default name Run 1 and click Next. At step 2, accept the single choice of OnionCreek as the
Basin Model and click Next. At step 3, accept Met 1 as the single choice of Meteorologic Model and click
Next. At step 4, accept Control 1 as the single choice of Control Specifications and click Finish. Close the
Simulation Run Manager.

On the top menu bar select Run 1.
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- R
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‘hrmant.REA 200 F3
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Click this button. The model should now run. You will see a number of warnings and a progress bar.
You can ignore the warnings for this exercise (though if doing this professionally you should check each).

You can right click on elements in the Basin Model window to view results at that location in Graph or

Table form.

() EEVJ#E
- Fi ﬂ%ﬁhmﬂnt—
Edit
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R View Results [Run 1]

Summary Table
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- | Time-5eries Table

—

Arrimem T Tame

Here is the graph of flow at the outlet.

. Graph for Junction "Junction-J9"
Junction "Junction-J9" Results for Fun "Run 1"
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Note a flow just over 100,000 cfs. Do you think this is realistic?
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Go to the USGS NWIS site for this watershed
http://waterdata.usgs.gov/nwis/inventory/?site no=08159000 and check peak streamflow at this

location.

If you click on the results for the subbasins, you can see the storm being applied to each. This is plotted
top down. The storm lasts for 6 hours but has a peak near the center that reflects high intensities
following the intensity-duration data that we inserted from City of Austin website.

F Graph for Subbasin "Catchment-10" = -E [
Subbasin "Catchment-10" Results for Run "Run 1"
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Legend (Compute Time: 270ct2015, 06:31:45)

— Run:Run 1 Elemert:Catchment-10 Result: Precipitation — Run:Run 1 Elemert:Catchment-10 Result: Precipitation Loss

Run:Run 1 Elemert: Catchiment-10 Result: Outflow — — — Rurn:Run 1 Element: Catchment-10 Rezult: Baseflow:

Flow {cfs)

Note that when displaying a time series table you can select the data and right click to export to a text
file.
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Compute Time: 230ct2015, 03:20:34 Control Specdifications:Control 1 atchmart4
Inflow from... Outflow
ent-B
(CFs) (CFs)
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Paste
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This is a convenient way to export the data to Excel for making comparative plots.

Prepare graphs where you show HEC-HMS hydrographs at the outlet and at an illustrative locations
about 1/2 of the way up Onion Creek from the outlet to the source. Prepare a map where you indicate
the locations where you have done these comparisons. These should show how the peak of the
hydrograph increases as one moves downstream and the basin area gets larger.

To turn in: Prepare a short report where you give the Hydrograph from HMS at the outlet and one other
location (about half way up from the outlet). Include a layout where you show these locations. Interpret
the graphs/results that you present. Include in your report at least one catchment where you show the
precipitation, precipitation loss and runoff.

OK. You are done!

Summary of Items to turn in.

1. Open the attribute table for the Subbasin feature class in Onion_HEC.gdb. For the largest subbasin
(Note that Subbasin in HEC corresponds to Catchments we delineated earlier) report the slope and
percentage imperviousness (Imp column). Compare these values to the values you calculated above
using zonal statistics.
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2. Prepare a short report where you give the Hydrograph from HMS at the outlet and one other
location (about half way up from the outlet). Include a layout where you show these locations.
Interpret the graphs/results that you present. Include in your report at least one catchment where
you show the precipitation, precipitation loss and runoff.
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