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DISCLAIMERS 

Although care has been taken in developing and testing GRAIP, errors and 
inadequacies may still occur, particularly in new applications. A user must therefore 
make the final evaluation as to the usefulness of GRAIP for their application. GRAIP 
is a tool to be used by investigators who have some knowledge and experience 
concerning analysis of the impact of roads on forested watersheds. It requires 
engineering judgment and common sense in developing input parameters and 
interpretation of the results. 

The authors of GRAIP assume no liability or responsibility for the use of GRAIP, the 
interpretation of GRAIP results, or the consequences of management decisions that 
are based upon GRAIP. In no event shall the authors be liable for any damages 
whatsoever arising out of the use, or attempts to use GRAIP. 

DISTRIBUTION 

Copyright (C) 2007-2009 David Tarboton, Utah State University 

This program is free software; you can redistribute it and/or modify it under the terms 
of the GNU General Public License version 2, 1991 as published by the Free 
Software Foundation. 

GRAIP is distributed from http://www.engineering.usu.edu/dtarb/graip/. 

This program is distributed in the hope that it will be useful, but WITHOUT ANY 
WARRANTY; without even the implied warranty of MERCHANTABILITY or 
FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License 
for more details.  

A copy of the full GNU General Public License is included in the file gpl.html with 
the source code. This is also available at:  
http://www.gnu.org/copyleft/gpl.html  
or from: 

The Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 
02111-1307, USA. 

If you wish to use or incorporate this program (or parts of it) into other software that 
does not meet the GNU General Public License conditions contact the author to 
request permission.  

http://www.engineering.usu.edu/dtarb/graip/
http://hydrology.neng.usu.edu/graip/gpl.htm
http://www.gnu.org/copyleft/gpl.html
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SUPPORT 

There is no formal ongoing support for this freely distributed open source software. 
However, we are interested in feedback. If you find errors, have suggestions, or are 
interested in any later versions contact: 

David G. Tarboton 
Utah State University 
4110 Old Main Hill 
Logan, UT 84322-4110 
USA 
 

http://www.engineering.usu.edu/dtarb/ 
email: david.tarboton@usu.edu 

CONVENTIONS USED IN THIS MANUAL 

A few conventions were established in developing this manual. Being aware of these 
conventions will make the manual easier to use. 

A. Detailed step-by-step instructions for the user to execute are listed as numbered 
steps in grey boxes. These are used both for the steps in the installation of the 
software and steps in the tutorial. 

B. Lists of items that are part of the general discussion and not specific steps to be 
executed are presented in lettered lists. 

C. The symbol  ->  indicates the next level in a tree structure or in nested menus. 

 

http://www.engineering.usu.edu/dtarb/
mailto:david.tarboton@usu.edu
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INTRODUCTION 

The Geomorphologic Road Analysis and Inventory Package (GRAIP) is a process 
and set of tools for analyzing the impact of roads on forested watersheds. This manual 
describes how to install and use this set of tools to perform a typical GRAIP analysis. 
Several tools were developed as part of GRAIP and are included with the package, 
such as the GRAIP Preprocessor and the GRAIP ArcGIS Toolbar. In addition, 
GRAIP also requires the use of several other software packages which must be 
acquired separately. This includes ArcGIS 9.1/9.2, TauDEM, Hawth's Tools and 
SINMAP2.0. 

GRAIP performs the following analyses to derive information on the environmental 
impact of roads on forested watersheds: 

A. Calculates and analyzes the production of road-based sediment and the input of 
that sediment into the stream network. 

B. Calculates the impact of road drainage on terrain stability and the potential for 
the formation of gullies due to erosion. 

C. Identifies fish passage passability at road-stream crossings and analyzes the 
resulting contiguity and fragmentation of the stream network fish habitat. 

OVERVIEW 

The construction and use of forest roads can have a significant negative impact on 
geomorphic processes and erosion patterns in forested basins. To analyze this impact, 
the Tarboton Group and the USDA Forest Service (USFS) developed the GRAIP 
(Geomorphologic Road Analysis and Inventory Package) process. Charles Luce and 
Thomas Black of the Forest Service developed much of the theory and the road 
inventory based approach which forms the foundation of GRAIP. Most of the work 
on the GRAIP tools was done by Ajay Prasad as his MS project under the supervision 
of David Tarboton. GRAIP is designed to help forest managers effectively manage 
road and road drainage systems and hence minimize the negative impacts of forest 
roads. 

The GRAIP process begins by creating a detailed road inventory using GPS (Global 
Positioning System) based surveys. Then, a GRAIP analysis uses a number of GIS 
tools including the GRAIP tools along with a DEM (Digital Elevation Model) to 
derive environmental impact information from this inventory.  Please note that the 
GRAIP system requires that the shapefiles developed as part of the road inventory 
and the DEM all must use the same coordinate system. GRAIP makes the assumption 
that they are the same, without actually checking to see that that is the case. 

The GRAIP analysis begins by using the GRAIP Preprocessor, a standalone 
application, to review the road inventory data for inconsistencies, document the 
inconsistencies, adjust and filter the data, and then builds the GRAIP database and the 
consolidated drain point and road shapefiles. This process ensures a minimum data 
quality and allows the data to be represented in a structured format that is more 
suitable for analysis. 
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The remainder of the analysis is performed using a number of tools including the 
GRAIP Toolbar, an ArcGIS 9.1/9.2 toolbar, that performs the heart of the analysis. In 
addition, a GRAIP analysis uses ArcGIS 9.1/9.2, TauDEM, Hawth's Tools and 
SINMAP2.0. 

The GRAIP Toolbar performs a number of analysis functions. The first group of 
functions calculates the sediment production for each road segment from slope, 
length, road surface condition and flow path vegetation. Road segment sediment 
production is then accumulated at each drain point. Digital elevation model (DEM) 
derived overland flow directions are then used to accumulate the sediment input to 
each stream segment. The second group of functions analyzes the impact of road 
drainage on terrain stability by calculating the specific discharge due to road drainage 
and using this, together with slope, as inputs to an infinite plane slope stability model. 
An erosion sensitivity index calculated using slope and contributing road length at 
each drain point is also calculated to predict gullying. The final function group 
analyzes the fragmentation of stream network fish habitat due to potential blockage of 
fish passage at stream crossings. 

INSTALLATION 

Prerequites 

A GRAIP analysis requires a number of software packages that are not included with 
GRAIP and they should be installed prior to installing GRAIP: 

1. Install ArcGIS with an ArcInfo and Spatial Analysis license. For more 
information, see the installation information that came with ArcGIS or the 
website http://esri.com/. 

2. Install TauDEM: The website http://hydrology.neng.usu.edu/taudem/ explains 
how to install and use the TauDEM toolbar. 

3. Install SINMAP2.0: The website http://hydrology.neng.usu.edu/sinmap2 
explains how to install and use the SINMAP toolbar. 

4. Install Hawth's Tools: The website http://www.spatialecology.com describes 
how to install and use Hawth's analysis tools. 

GRAIP Setup 

Once these packages have been installed, GRAIP itself can be installed. 

5. Install the GRAIP Toolbar and GRAIP Preprocessor: The website  
http://www.engineering.usu.edu/dtarb/graip/ provides a link to the GRAIP GIS 
Tool setup file: “GRAIPSetup.exe”. Download GRAIPSetup.exe and save it to 
your working folder. Double click to run the setup. 

This will install GRAIP in the designated folder (by default C:\Program 
Files\GRAIP). The GRAIP installation includes: 

A. An executable, GRAIPPreprocessor.exe, and 3 binary libraries, 
consolidateShp.dll, agGRAIP.dll and graipCOMDLL.dll. These file make up 
both the Preprocessor and the ArcGIS toolbar. 

B. The GRAIP database template, GRAIP.mdb, located in the graip db folder. This 
file is required by the Preprocessor. 

http://esri.com/
http://hydrology.neng.usu.edu/taudem/
http://hydrology.neng.usu.edu/sinmap2
http://www.spatialecology.com/
http://www.engineering.usu.edu/dtarb/graip/
http://www.engineering.usu.edu/dtarb/graip/
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C. A tutorial folder that contains this manual and a zipped file of data needed for 
the tutorial. This zip file contains a ‘demo’ folder which contains the “dem” 
(ESRI Raster Grid) file and a shapefiles folder containing eight types of drain 
points shapefiles (BBdip.shp, Diffuse.shp, Ditchrel.shp, Lead_off.shp, ned.shp, 
Str_Xing.shp, sump.shp, waterbar.shp) and one road lines shapefile (road.shp). 

D. A shortcut to the GRAIP Database Preprocessing tool that is installed in the 
Start-> Programs menu. 

ArcGIS-GRAIP Toolbar Configuration 

6. Start ArcMap by clicking the windows Start button and selecting All Programs -
> ArcGIS -> ArcMap. 

7. Select Tool -> Customize to open this dialog: 

 

8. Click the Add from file… button to open the Open dialog. 

9. Browse to the \Program Files\GRAIP folder. 

10. Select the agGRAIP.dll file, click the OK button. 

11. Click the Close button. 

12. Check the “Geomorphologic Road Analysis and Inventory Package (GRAIP)” 
checkbox. 
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13. Click the “Close” button to make this toolbar visible. 

 

ArcGIS-Spatial Analyst Configuration 

GRAIP uses features from ArcGIS’ Spatial Analyst extension and so this extension 
must be unlocked. To do this: 

14. Select Tool -> Extensions to open this dialog: 
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15. Click on Spatial Analyst and then click the Close button. 

Installing the Tutorial Files 

If you wish to work through the tutorial examples, you will also need to install the 
tutorial files. 

16. Unzip the C:\Program Files\GRAIP\tutorial\demo.zip file to a convenient 
working folder. For the purpose of the tutorial examples, we have used C:\demo. 

TUTORIAL 

This tutorial describes the steps taken in a typical GRAIP analysis. 
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PREPROCESSOR 

Introduction 

The GRAIP Preprocessor is an application that validates and imports USFS road 
inventory shapefile attributes into a relational database structure created in the MS 
Access file format. The purpose of this database (the GRAIP Database) is to enforce 
referential integrity and ensure consistency between related attributes. The 
Preprocessor helps to correct and/or screen out invalid or corrupt data so the user has 
a better dataset with which to perform the forest road impact analysis. It also 
consolidates multiple drain point and road line shapefiles, creating a single shapefile 
for each. 

Starting the Preprocessor 

1. Start the GRAIP Preprocessor by clicking the windows Start button and selecting 
All Programs -> GRAIP -> GRAIP Preprocessor. 

This screen will appear: 

 

2. Click on the More Button (…) next to the Project File field. Browse to your 
tutorial working folder where you unzipped the demo data, use the file name 
“test.graip” and click Save. 
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An initial path and file name for the GRAIP Database file will be generated based on 
the path and file name selected. 

3. Click on the More button (…) next to the DEM File field. Browse to the 
\DEM\dem folder in your tutorial working folder, select the sta.adf file and click 
“OK”. See the location of the DEM\dem\sta.adf file used in this example: 

 

4. Click on the Add button adjacent to Road Shapefiles field. Browse to the 
\ShapeFiles\ folder in your tutorial working folder, select Select the Road.shp 
file, and click “OK”. 

5. Click on the Add button adjacent to Drain Points Shapefiles field. Select the 
following files from the Shapefiles directory by holding down the Ctrl key and 
clicking on each filename in this list: BBdip.shp, Diffuse.shp. DitchRel.shp, 
LeadOff.shp, Ned.shp, Str_Xing.shp, Sump.shp, WaterBar.shp. Release the Ctrl 
key and click OK. 

Your screen should now look like this: 
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6. Click the “Options” button to open the dialog shown below: 
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The Options dialog allows you to choose the type of processing the Preprocessor will 
perform. Uninterrupted processing does not display any dialogs. It just uses all of the 
defaults and continues until all of the shapefiles are processed. Step by Step 
processing stops at each of the shapefile import screens allowing the user to adjust the 
options before importing each shapefile. Also if you choose Step by step processing, 
you have another choice to make, Manual resolution of invalid/missing values. If you 
select this option, anytime there is a value in an attribute field that is not in the 
dictionary for that field, a screen pops up to decide how to handle the situation. If you 
do not select this option, the preprocessor will use the default values and continue 
with the processing. In all cases, all data issues are logged for later review. This 
dialog also allows you to change the log file names and paths. 

7. For the purpose of this tutorial, do not change any of the options. Just click 
Cancel”. 

8. Click Next. 

The first Import Drain Point Shapefile screen for matching fields from the first drain 
point shapefile to the appropriate target field in the GRAIP database table appears. 

Before proceeding let's see what has been done. If you look in the working folder 
where the demo data was unzipped, you should see that a new GRAIP project file 
(test.graip) has been created which holds the lists of files that are part of the project. 
A new MS Access database file (test.mdb and test.ldb) has also been created. All the 
shapefile attributes will be validated and stored in this database file. Two logfiles 
(testDP.log and testRD.log) have been created as well. 

Import Drain Point Attributes 

Let's now return to the first Import Drain Point Shapefile screen shown: 
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The File being imported field displays the path of the next drain point shapefile to be 
imported. This comes from the list of shapefiles identified earlier. The Drain Point 
Type default value is automatically selected by the program based on the name, but 
can be changed by the user. 

The Set Field Names table is used to designate the fields from the drain point 
shapefile that will be imported into the GRAIP database. The Target Field column 
lists the fields in the GRAIP database and the Matching Source Field column 
indicates how each field in the GRAIP database is to be filled, either with a default 
value or from a field in the drain point shapefile. The tool will attempt to match the 
fields by default, but if no default is found, “<No Match Use Default>” is used. If any 
of the default values need to be changed, click on that row in the Matching Source 
Field column and a list of choices will appear on a drop down menu: 
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9. In this example, the defaults are acceptable, so click Next. 

A progress bar will appear at the bottom of the screen while the shapefile is imported. 

10. For the 2
nd

 to 5
th
 drain point shapefiles the defaults are acceptable so continue to 

click next. 

As the Str_Xing shapefile is being imported (the 6
th
 of 8) after you have clicked Next 

on its Drain Point Import Screen, an attribute value of "<25 degrees" is found in the 
ChannelAngleID field, which is not defined in the ChannelAngleDefinitions table. 
The Define Value dialog appears to help you resolve this issue: 
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You now need to decide how you want the Preprocessor to handle all occurrences of 
this undefined value in this field. Your choices are to use the default defined value for 
this field (shown next to the Use default value label), reassign all occurrences of this 
value to one of the existing defined values, or create a new definition for this value. 

11. For this tutorial, click Use default value. 

The choices made on resolving mismatched during data import are recorded in the 
DPErrorLog table and testDP.log file. 

12. Click Ok. 

Once all of the invalid values in that drain point table are processed, the next drain 
points validate and import screen is displayed. 

13. Continue these steps clicking "OK" or "Next" and resolving invalid/missing 
values until all the drain point shapefiles are imported to the database. 

Once all the drain points shapefiles are validated and imported, the Road Lines import 
screen is displayed. 

Import Road Lines Attributes 

The Road Lines Import screen looks like this: 
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The File being imported field displays the path of the road line shapefile to be 
imported. This comes from file selected in the initial Preprocessing screen. The Road 
Network field shows the road network type. The Base Erosion Rate field shows the 
rate associated with this road network type. The Description field gives an 
explanation for the base rate used. The + button is used to add an additional road 
network type along with it’s associated base rate and description. The - button is used 
to remove a road network type and its associated base erosion rate. The Default road 
network type cannot be removed. 

The Set Field Names table is used to designate the fields from the drain point 
shapefile that will be imported into the GRAIP database. The Target Field column 
lists the fields in the GRAIP database and the Matching Source Field column 
indicates how each field in the GRAIP database is to be filled, either with a default 
value or from a field in the drain point shapefile. The tool will attempt to match the 
fields by default, but if no default is found, “<No Match Use Default>” is used. If any 
of the default values need to be changed, click on that row in the Matching Source 
Field column and a list of choices will appear on a drop down menu: 
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14. In this example, the defaults are acceptable, so click Next. 

As the Road.shp shapefile is being imported, an attribute value of >50’ is found in the 
FillChannelID field, which is not defined in the FillChannelDefinitions table. The 
Define Value dialog appears to help you resolve this issue: 
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15. Click Use default value and click “OK”. 

16. Continue resolving invalid/missing values until the road line shapefile is 
imported to the database. 

The consolidate shapefiles progress bar will appear while the shapefiles are being 
consolidated. 

Preprocessor Output Files 

Here is a list of the output files created by the GRAIP Database Preprocessor tool: 
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The output files include 2 log files that identify the issues found with the data during 
operation of the preprocessor.  A copy of this information can also be found in 2 of 
the tables in the Access database file. 

DATA PREPARATION 

This data preparation step should be done before using the GRAIP GIS Tool: 

17. Start ArcMap by clicking the windows “Start” button and selecting All Programs 
-> ArcGIS -> ArcMap. 

18. Click the Add Data tool  from ArcMap’s Standard toolbar, browse to the 
DEM folder in the demo folder, select the dem grid and click Add. 

19. Perform the Basic Grid Analysis -> Select Base DEM grid … and Basic Grid 
Analysis -> Do All functions of the TauDEM toolbar. See 
http://hydrology.neng.usu.edu/taudem/ for more information. 

Now you need to identify the outlet of the watershed you will be working with. To do 
this, use ArcCatalog to create a new empty point type shapefile named "Outlet". 

20. Start ArcCatalog by selecting Tools -> ArcCatalog. 

21. Right click on the Shapefile folder in the demo folder where you are working 
and select 'New/Shapefile...'. Set the name 'Outlet' and set the feature class to 
point. Click OK to create the shapefile. 

Then add the outlet point to the new shapefile. 

22. Switch back to ArcMap. Click the Add Data tool  from ArcMap’s Standard 
toolbar, browse to the Shapefiles folder in the demo folder and select Outlet.shp. 
If the Editor toolbar is not visible, Select View -> Toolbars -> Editor to display 
it. Select Editor -> Start Editing from the Editing toolbar. Select the 
\demo\Shapfiles folder and click OK. Select Outlet.shp, and click Start Editing. 

23. Use the layer demsrc.src to ensure that you are locating a point on a stream path. 

Click the Add Data tool  from ArcMap’s Standard toolbar, to add the 
DrainPoints shapefile. 

The demsrc.src layer with the DrainPoints file looks like this (except it won’t have 
the red box): 

http://hydrology.neng.usu.edu/taudem/
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24. Use the Magnifying Glass tool to zoom in on the downstream area of the 
watershed (which was highlighted by the red box in the previous image). 

25. Use the Sketch tool to carefully locate a point at the outlet of the watershed 
(downstream of all of the drain points). 

Your point should look something like this: 
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.

 

26. Select Editor -> Stop Editing, and then Save. 

If you had difficulties creating the outlet file and adding your outlet point, instead you  
can use the Outlet1.shp file that is in the demo folder. Outlet.shp (or Outlet1.shp if 
you are using the pre-built file) is now a one point shapefile. 

27. Run the Network Delineation functions of the TauDEM toolbar using Outlet.shp 
as the outlets file to delineate a stream network based on the DEM. See 
http://hydrology.neng.usu.edu/taudem/ for more information. 

GRAIP TOOLBAR MENU & TOOLS 

The GRAIP toolbar has the following menus: 

 

 

 

 

B 
 

A C D E G F 

http://hydrology.neng.usu.edu/taudem/
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A. File Menu—to set and adjust project settings and files. 

B. Preprocessor Menu—to perform several preliminary steps necessary to a 
GRAIP analysis 

C. Road Surface Erosion Analysis Menu—to quantify sediment production from 
forest roads and its delivery to streams. 

D. Mass Wasting Potential Analysis Menu—to quantify the impact of forest 
roads on terrain stability and gullying potential. 

E. Habitat Segmentation Analysis Menu—to analyze and demarcate fish habitat 
segmentation due to failed or blocked culverts. 

In addition to the menus, there are two tools on the GRAIP toolbar: 

F. Drain Rex—to trace the road segments draining to a particular drain point. (Rex 
being the faithful dog to sniff out where road segments drain.) 

G. Road Rex—to find drain points to which a particular road segment is draining. 

FILE MENU 

Open Function 

The Open function opens the project file that contains information about files and 
paths for the GRAIP analysis that was created by the GRAIP Preprocessor. 

28. Select “File” -> “Open” from the GRAIP Toolbar. 

 

29. In the Open dialog, browse to your working folder and select the test.graip 
project file that was created by the GRAIP Preprocessor. Click Open. 

Once this has been opened, the DEM, DrainPoints.shp, RoadLines.shp and 
demnet.shp files will be loaded and displayed in ArcMap. ArcMap’s Table of 
Contents should look like this: 
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When the project file is used to load the files, the RoadLines and DrainPoints 
shapefiles are also joined to their corresponding tables in the GRAIP Database 
(*.mdb) so that the attributes are available for analysis. This allows to open the 
RoadLines shapefile attribute table and see the data stored in the RoadLines database 
table: 

 

File Management Function 

To view the default file names and paths that will be used for this analysis or if there 
is a need to change any of the files or file paths for any of the input, intermediate or 
output files, use the File Management function. 

30. Select File -> File Management to open the File Management dialog as shown: 
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Here you can review the default file names and make any necessary adjustments. For 
this tutorial, we will not make any changes. 

31. Click Cancel. 

PREPROCESSOR MENU 

Resample DEM Function 

This function resamples a DEM to a finer scale using the cubic convolution method 
from the ArcGIS Toolbox. 

32. Select Preprocessor -> Resample DEM on the GRAIP Toolbar to get the 
“Resample” dialog as shown here: 
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33. Click Compute. 

Extract Stream Crossings Function 

This function extracts the stream crossing drain points from the consolidated 
DrainPoints shapefile created by the GRAIP Preprocessor. 

34. Select Preprocessor -> Extract Stream Crossings from the GRAIP toolbar to get 
the screen shown: 

 

35. Click “Extract”. 

Hawth’s Tool-Intersect Lines (Make Points) Function 

This function creates a shapefile containing points that are the intersections of the 
roads from the RoadLines shapefile with the stream network generated by TauDEM. 

36. Select Hawth’s Tools -> Vector Editing Tools -> Intersect Lines (Make Points) 
from the Hawth’s Tools toolbar to get the “Intersect Lines (Make Points)” 
dialog. 

37. Select RoadLines as the Line/poly layer, demnet as the Intersect line/poly layer 
and for the Output point shapefile, browse to the folder you are using for this 
tutorial and name the file StrXingRi.shp so the screen looks like this: 
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38. Click the OK button. Click OK on the confirmation screen. 

Hawth’s Tools-Snap Points to Lines Tool Function 

This function will create a new point shapefile that contains the drainpoints after they 
have been adjusted so that they actually lie on the preliminary stream network that 
was created by TauDEM. 

39. Select Hawth's Tools -> Vector Editing Tools -> Snap Points to Lines Tool from 
the Hawth’s Tools toolbar to get the “Snap Points To Lines” dialog. 

40. Select StrXingEx as the Point feature layer and demnet as the Line or polygon 
feature layer. For the New point layer to create, browse to the folder you are 
using for the tutorial and name the file “StrXingSn.shp”. 
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41. Click the OK button. Click OK again on the confirmation screen. 

Filter Stream Crossings Function 

This function automatically associates the appropriate points on the stream network 
from the snapped stream crossings file (StrXingSn.shp), and the points that are road-
stream intersections (StrXingRi.shp), with nearby surveyed stream crossings 
(StrXingEx.shp), screened according to nearness and a geomorphologically derived 
channel width criterion. Three shapefiles are created by this function, one containing 
all of the merged stream crossings (MergedSX.shp), one containing only the matched 
stream crossings (MatchSX.shp) and the last containing only the unmatched stream 
crossings (UMatchSX.shp). 

The goal of this function is to position each surveyed stream crossing from 
StrXingEx.shp on the stream network. This is attempted by examining both the 
nearest position on the stream to which the stream crossing can be snapped 
(StrXingSn.shp) and the nearest road stream intersection (StrXingRi.shp). Points that 
passed one or both of these criteria are in MatchSX.shp. The user should in most 
cases be able to accept these without further analysis. The surveyed stream crossings 
for which there was no match found are placed in UMatchSX.shp. 

Please Note: This function requires the ArcInfo license. 

42. Select Preprocessor -> Filter Stream Crossings from the GRAIP toolbar from the 
GRAIP toolbar as shown: 
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43. Click Compute. 

At this point, the user might want to use ArcGIS or other GIS tools to review the 
unmatched stream points, examining why they are not placed on a stream, making 
appropriate edits to place them on a stream, and/or identifying situations requiring 
further examination in the field. For the purposes of this tutorial, we will accept the 
matched and unmatched stream crossing shapefiles as they were created. 

ArcGIS Combine Outlets Task 

Now you need to use the ArcGIS tools to create a revised outlets file that contains a 
combination of all of the matched on-stream points along with the original outlet 
points from the original outlets file (outlet.shp). As part of this you need to make sure 
that the Id field is unique.  Since the Ids of the matched stream points are already 
unique, you just need to make sure that the Id of the original outlet is not a duplicate 
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of any of the matched stream point Ids. Also, be sure not to change any of the 
matched stream point Ids since they are used in the fish habitat analysis. 

44. Select Editor -> Start Editing from ArcMap’s Editor toolbar to show the Start 
Editing dialog. Click on the C:\demo folder (or the folder that contains the 
outlet.shp file) and click OK. You will receive a warning abou the editing being 
in a different coordinate system. Click Start Editing. In the Editor toolbar, set the 
taret layer to “Outlet.” Right click on the MatchSX layer and select “Open 
Attribute Table” to show the Attributes of MatchSX dialog. Click the Options 
button and select “Select All”. Select Edit -> Copy. Click on the Close Box. 
Right click on the Outlet layer and select “Open Attribute Table” to show the 
Attributes of Outlet dialog. Select Edit ->Paste. Click on the Close Box. Select 
Editor -> Stop Editing. Click Yes when asked if you want to save your edits. 

If you have any difficulty with this step, you can use the Outlet2.shp file that is in the 
demo folder. 

Create TauDEM Stream Network Function 

This function runs the TauDEM Stream Network utility to create a new stream 
network shapefile using the revised outlets shapefile which contains both the original 
outlet point as well as the corrected stream crossing points. This revised stream 
network shapefile is similar to the previous version except that the stream segments 
are split at stream crossings. 

45. Select Preprocessor->Create TauDEM Stream Network from the GRAIP toolbar 
to get the Outlets Shapefile screen shown: 

 

46. Click Compute. When asked if it is OK to overwrite files, click OK. 

ROAD SURFACE EROSION ANALYSES MENU 

The functions on the GRAIP toolbar menu Road Surface Erosion should be run in 
sequence from top to bottom. 
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Road Segment Sediment Production Function 

The Road Segment Sediment Production function calculates sediment production 
values for each stream segment according to: 

2
  E

i

aLSrv
 

where E is the erosion from each forest road segment in kg/yr, i indicates the side of 
the road, a is the annual base erosion rate (with 79 kg/yr being the default, although a 
different value could be defined for each road segment shapefile when it is imported 
with the preprocessor), L is the road segment length, S is the slope, r is the road 
surface multiplier which varies depending on the type of road surface, and v is the 
flow path vegetation multiplier which varies depending on the density of the flow 
path vegetation.  Please realize that LS is also equal to the difference in maximum and 
minimum elevations in the road segment. 

The three parameters, a, r and v are stored in the following field/tables in the project 
database which for the tutorial is located at C:\demo\test.mdb: 

A. a (annual based erosion rate) --> BaseRate field in the RoadNetworkDefinitions 
table 

B. r (road surface multiplier) --> Multiplier field in the SurfaceTypeDefinitions 
table 

C. v (flow path vegetation multiplier) --> Multiplier field in the 
FlowPathVegDefinitions table 

These parameters can be edited prior to executing this step by double clicking on the 
test.mdb file in the file explorer. Then double click on the table for the desired 
parameter and edit the field listed for that parameter.  Changes are automatically 
saved when you exit each record. 

The Road Sediment Production function populates the following fields in the 
RoadLines table in the GRAIP database, test.mdb: 

A. Length-Road length (meters) 

B. SedProd1-Sediment production for one side of the road (kg/yr) 

C. SedProd2-Sediment production for the other side of the road (kg/yr) 

D. UnitSed-Unit sediment production from the road segment (kg/m/yr) 

E. TotSedProd-SedProd1+SedProd2 (kg/yr) 

F. TotSedDel-Sediment delivered to streams (calculated using stream connection 
information for each road) (kg/yr) 

G. UnitTotSedDel-TotSedDel/Length (kg/m/yr) 

 

47. Select Road Surface Erosion Analysis -> Road Segment Sediment Production 
function to show this screen: 
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48. Click Compute. 

Drain Point Sediment Accumulation Function 

This function calculates sediment accumulation values for each drain point. As part of 
this, the following drain point fields are populated: 

A. SedProd-Total accumulated sediment load at each drain point due to road surface 
erosion (kg/yr) 

B. ELength-Effective length of road draining to each drain point (meters) 

C. UnitSed-SedProd/Elength (kg/m/yr) 

D. SedDel-Sediment delivery depending on stream connection (kg/yr) 

49. Select Road Surface Erosion Analysis ->Drain Point Sediment Accumulation 
function to open this screen: 
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50. Click Compute. 

Accumulated Upstream Sediment Load Function 

This function creates the following output grids: 

A. Weight grid with Drain Point accumulated sediment load (with a *swt name 
format). 

B. Weighted Sediment Accumulation grid (with a *sac name format). 

The user can select between D8 and Dinf Contributing area functions. 

51. Select Road Surface Erosion Analysis-> Accumulated Upstream Sediment Load 
function in the GRAIP toolbar to show this screen: 



GRAIP 1.0  Geomorphologic Road Analysis and Inventory Package 

Tutorial Manual  36 

 

52. Click Compute. 

Accumulated Upstream Specific Sediment Function 

This function creates the upstream specific sediment accumulation grid (with a *spe 
name format). 

53. Select Road Surface Erosion Analysis -> Accumulated Upstream Specific 
Sediment function to show the following screen. 

 

54. Click Compute. 
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Upstream Stream Sediment Input Function 

This function calculates sediment accumulation for the downstream end of each 
stream segment. The following fields are appended to the stream network shapefile 
(that has a *net.shp name format): 

A. SedAccum-Accumulated Sediment Inputs for each stream segment (kg/yr). 

B. SpecSed-Accumulated Specific Sediment Load per unit area for each stream 
segment (Mg/km2/yr). 

55. Select Road Surface Erosion Analysis-> Upstream Stream Sediment Input 
function to show this screen. 

 

56. Click Compute. 

Direct Stream Sediment Input Function 

This function calculates the sediment load for the area draining directly to stream 
segment. These fields are appended to the stream network shapefile (that has a 
*net.shp name format). 

A. SedDir-Direct Sediment Inputs for each stream segment (kg/yr). 

B. SpecSedDir-Direct Specific Sediment Load per unit area for each stream 
segment (Mg/km2/yr). 

57. Select Road Surface Erosion Analysis->Direct Stream Sediment Input function 
from the GRAIP toolbar to show this screen: 
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58. Click Compute. 

MASS WASTING POTENTIAL ANALYSIS MENU 

The functions on the Mass Wasting Potential Analysis Menu (Figure 20) should be 
run in a sequence from top to bottom. 

 

SINMAP 2.0 Stability Index & Calibration Region Grid Functions 

SINMAP2.0 is used to create a Stability Index (SI) grid and a calibration region grid 
from the DEM. Calibration regions are areas within which single lower bound and 
upper bound calibration parameters values can represent T/R, dimensionless 
cohesion, friction angle (ø) and soil density (ρ). 

59. Run SINMAP 2.0 to create a Stability Index (SI) grid 
(C:\demo\DEM\SINMAPData\demsi) and a calibration region grid 
(C:\demo\DEM\SINMAPData\demcal) from the DEM. For more information on 
using SINMAP 2.0, see http://hydrology.neng.usu.edu/sinmap2/. 

Stability Index Function 

This function looks up the Stability Index grid values at each drain point and stores 
them in the SI field in the DrainPoints table. 

60. Select Mass Wasting Potential Analysis -> Stability Index from the GRAIP 
toolbar to show this screen: 

http://hydrology.neng.usu.edu/sinmap2/
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61. Click compute. 

Combined Stability Index Function 

This function creates a Combined Stability Index Grid (with a *sic file format) and 
stores the value from that grid at each drain point in the SIR Field of the drain pint 
table in the GRAIP database. 

62. Select Mass Wasting Potential Analysis -> Select Calibration Region Grid and 
browse to the calibration region grid (C:\demo\DEM\SINMAPData\demcal) to 
get the screen shown: 
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63. Click the “Add” button. 

The grid is added to ArcMap and default combined stability index parameters are 
written to the parameter file (suffix *calp.csv). 

64. Select Mass Wasting Potential Analysis -> Combined Stability Index from the 
GRAIP toolbar to show this screen: 
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The View/Edit Calibration Parameter File button on the Combined Stability Index 
dialog can be used to open the Parameter Values of the Calibration Grid dialog 
shown: 

 

These parameters are user adjustable. But for the purposes of this tutorial, we will not 
open the dialog.  The user may also select a different combined stability index 
calibration parameters file.  If doing so, ensure that the value column matches the 
values in the grid or else an error may occur. 

Note that this function computes a combined stability index considering terrain 
drainage and additional road surface runoff.  Road surface runoff is evaluated only at 
the drain point types indicated.  Additional runoff from other drain points is not 
considered.  Road surface runoff is evaluated as road width times the road surface 
runoff parameters given times the effective length of road segments to each drain 
point. 

65. Click Compute. 

The output and intermediate files created are: 

A. Minimum and maximum depth of terrain runoff generated (with *rmin and 
*rmax file formats). 

B. Specific discharge due to road drainage for Minimum runoff and Maximum 
runoff (with *rdmin and *rdmax file formats). 

C. Combined Stability Index Grid (with a *sic file format). 

The intermediate outputs (A) and (B) are not added to ArcMap. The output file (C) is 
added if the “Add SI combined grid to the Map” checkbox is checked which is the 
default. 

In this function, stability index (SI) due to terrain contributing area can be calculated 
by setting the road surface runoff to be 0, and SI due to road runoff only can be 
computed setting terrain recharge to be 0. The SI values from the grid are used to 
identify SI values to store in the SIR Field in for each drain point in the GRAIP 
database. 

D8 Slope Grid with Downslope Averaging Function 

This function uses the D8 flow directions approach to trace downslope and find the 
average slope for each grid cell over the specified averaging distance. The output 
from this function is the slope grid with downslope averaging (Suffix .slpd). 

66. Select Mass Wasting Potential Analysis -> D8 Slope Grid with downslope 
averaging from the GRAIP  toolbar to show this screen: 
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67. Click Compute. 

Slope at Drain Point Function 

This function calculates the slope at each drain point and stores it in the Slope field in 
the DrainPoints table of the GRAIP database. 

68. Select Mass Wasting Potential Analysis -> Slope at Drain Point from the GRAIP 
toolbar to open this screen: 

 

69. Click Compute. 

Distance to Stream Function 

TauDEM includes a function to evaluate Flow Distance to Streams.   

70. Select Specialized Grid Analysis -> Flow Distance to Streams from the TauDEM 
toolbar to open this screen: 
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71. Click Compute. 

Distance to Stream From Drain Point 

72. Select Mass Wasting Potential Analysis -> Distance to Stream from Drain Point 
from the GRAIP toolbar to open this screen: 

 

73. Click Compute. 

Erosion Sensitivity Index Function 

This function populates the ESI field in the DrainPoint table ESI is calculated as LS
α
 

where S is the slope and L is the Effective Length of the road draining to each drain 
point. 

74. Select Mass Wasting Potential Analysis -> Erosion Sensitivity Index from the 
GRAIP toolbar to show this screen: 
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75. Click Compute. 

Length Slope Plot Function 

This function shows the Length-Slope plot with Length on the Y-axis and Slope on 
the X-axis. 

76. Select Mass Wasting Potential Analysis -> Length Slope Plot from the GRAIP 
toolbar to show this screen: 
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77. Click the Close icon in the upper right corner of the dialog. 

Stream Blocking Index Function 

This function populates these fields in the DrainPoints table in the GRAIP database: 

A. SBI: Stream Blocking Index indicating plugging susceptibility based on the ratio 
of pipe diameters to channel width ratio class and skew angle score. 

B. PipeDiaToChannelWidthScore: Ratio of pipe diameter divided by channel width 
ratio class. 

C. SkewAngleScore: Skew angle score. 

78. Select Mass Wasting Potential -> Stream Blocking Index from the GRAIP 
toolbar to show this screen: 

 

79. Click Compute. 

HABITAT SEGMENTATION ANALYSIS MENU 

Fish Passage Barrier Function 

This function identifies the fish passage barriers and assigns an identifier representing 
the status of the stream crossing: 0-Blocked Passage, 1- Possible Passage and 2- Clear 
Passage.  This identifier is used to populate the Barrier field in the DrainPoints table 
in the GRAIP database.  Possible Passage identifies the stream crossings that may be 
passable to some species, but not to others. 

80. Select Habitat Segmentation Analysis -> Fish Passage Barrier from the GRAIP 
Toolbar to show this screen: 
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81. Click Compute. 

Fish Habitat Segmentation Function 

This function assigns an identifier to each stream segment indicating the habitat 
cluster to which it belongs. The habitat cluster identifier is appended to the TauDEM 
stream network shapefile attribute table. 

82. Select Habitat Segmentation Analysis -> Fish Habitat Segmentation function 
from the GRAIP toolbar to show this screen:  
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83. Click Compute. 
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REFERENCE MANUAL 

USFS ROAD INVENTORY TABLES DATA DICTIONARY 

Roads Shapefile Attribute Table 

Field Name Description 
SURF_TYPE Road surface type 
SURF_COND Road surface condition 
ROAD_TYPE System road or high clearance 
RD_EDGE_1 Cut slope height or road edge feature 
RD_EDGE_2 Cut slope height 2 or road edge feature 
EDGE_VEG_1 Roadside vegetation density 1 
EDGE_VEG_2 Roadside vegetation density 2 
EDG_CND_1 Edge condition 1 
EDG_CND_2 Edge condition 2 
FLOW_PATH1 Location of flowing water 1 
FLOW_PATH2 Location of flowing water 2 
FLWPTH_VG1 Vegetation on flow path 1 
FLWPTH_VG2 Vegetation on flow path 2 
FLWPTHCND1 Condition of flow path 1 
FLWPTHCND2 Condition of flow path 2 
FILL_CHAN Fill slope toe to channel edge distance in feet 
SURF_COV Road surface cover 
CDATE Survey collection date 
CTIME1 Survey collection time 1 
CTIME2 Survey collection time 2 
VEHICLE Survey vehicle used 
COMMENT Additional information about the road segment 

 

Broad Based Dip Drain Point Shapefile Attribute Table 

Field Name Description 
SLOPE_SHAP Shape of the slope 
DISCHRG_TO Destination of discharge (i.e., gully, forest floor) 
STREAM_CON Stream connection 
OBSTRUCT Debris in flow path of drain 
FILL_EROS Fill erosion present or not 
TYPE Broad based dip type 
CONDIT Condition of the drain point 
MATERIAL Material found in the drain point 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 
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Diffuse Drain Point Shapefile Attribute Table 

Field Name Description 
SLOPE_SHAP Slope shape 
DISCHRG_TO Destination of discharge (i.e., gully, forest floor) 
STREAM_CON Stream connection present or not 
OBSTRUCT Debris in flow path of drain 
FILL_EROS Fill erosion present or not 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 

 

Ditch Relief Drain Point Shapefile Attribute Table 

Field Name Description 
SIZE Pipe diameter in inches 
TYPE Culvert material 
SLOPE_SHAP Slope shape 
DISCHRG_TO Destination of discharge (i.e., gully, forest floor) 
STREAM_CON Is there a stream connection? 
FILL_EROS Fill slope eroded below pipe? 
FLOW_DIVER Presence of flow diversion? 
OBSTRUCT Debris in flow path of drain? 
FLOW_DIFFU Flow diffuser type 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
PIPE_LEN Pipe length in feet 
CONDIT Sediment occlusion 
VEHICLE Survey vehicle used 

 

Lead-off Drain Point Shapefile Attribute Table 

Field Name Description 
SLOPE_SHAP Slope shape 
DISCHRG_TO Discharge to (i.e. gully, forest floor) 
STREAM_CON Stream connection present or not? 
CONDIT Condition 
OBSTRUCT Debris in flow path of drain 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 
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Non-Engineered Drain Point Shapefile Attribute Table 

Field Name Description 
SLOPE_SHAP Slope shape 
DISCHRG_TO Destination of discharge (i.e., gully, forest floor) 
STREAM_CON Stream connection present or not? 
OBSTRUCT Debris in flow path of drain? 
FILL_EROS Fill erosion present or not? 
CONDIT Condition 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 

 

Stream Crossing Drain Point Shapefile Attribute Table 

Field Name Description 
TYPE Culvert Material 
R_PIPE_DIA Round pipe diameter in inches 
OVAL_PIPE Oval pipe size 
PIPE_LEN Pipe length in feet 
CHAN_WDTH Channel width in feet 
PIPE_NUM Number of pipes used 
FILL_DEPTH Fill depth in feet 
CONDIT Condition 
CHAN_ANGL Angle between pipe and channel 
BLOCK_TYP Evidence of blockage 
OUTLET_DRP Outlet drop measured below pipe in feet and tenths 
PL_DEPTH Depth below outfall in feet and tenths 
PIPE_GRADE Grade measured in percent 
SUBSTRATE Crossing substrate 
DEBRIS_FLW Debris flow 
FILL_EROS Fill erosion 
DIVERSION Presence and direction of channel diversion 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 

 

Sump Drain Point Shapefile Attribute Table 

Field Name Description 
CONDIT Condition 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 
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Water Bar Drain Point Shapefile Attribute Table 

Field Name Description 
SLOPE_SHAP Slope shape 
DISCHRG_TO Destination of discharge (i.e.; gully, forest floor) 
STREAM_CON Stream connection present or not? 
OBSTRUCT Debris in flow path of drain? 
FILL_EROS Fill erosion present or not? 
TYPE Drain point material 
CONDIT Condition 
COMMENT Comment 
CDATE Survey collection date 
CTIME Survey collection time 
VEHICLE Survey vehicle used 
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GRAIP DATABASE TABLES 

MASTER TABLES 

DrainPoints Table 

Field Name Description Menu Function 
GRAIPDID Unique drain point identifier. Primary 

key. 
Preprocessor 

DrainTypeID Type of drain point Preprocessor 
CDate Survey collection date Preprocessor 
CTime Survey collection time. 10 character text 

field. 
Preprocessor 

VehicleID Survey vehicle identifier Preprocessor 
DrainID Numeric drain point identifier built from 

the CDATE, CTIME and VEHICLEID 
fields.  Should be unique for each drain 
point. 

Preprocessor 

StreamConnectID Stream connection present or not. Field 
not in SteamCrossing or Sump 
shapefiles.  Data is populated by 
assuming 2 (Yes) for all StreamCrossing 
drain points and 1 (No) for all Sump 
drain points. 

Preprocessor 

Comments Description or comments about the drain 
point feature 

Preprocessor 

SedProd Accumulated road sediment load to each 
drain point (kg/yr) 

Drain Point 
Sediment 
Accumulation 

ELength Effective length of the road draining to 
each drain point (m) 

Drain Point 
Sediment 
Accumulation 

UnitSed Drain point unit sediment load (kg/m/yr) Drain Point 
Sediment 
Accumulation 

SedDel Sediment load delivered to streams 
(kg/yr) 

Drain Point 
Sediment 
Accumulation 

SI SINMAP stability index values at each 
drain point 

Stability Index 

SIR SINMAP stability index values at each 
drain point accounting for road runoff 

Stability Index 

Slope Slope at each drain point Slope at Drain 
Point 

ESI Erosion sensitivity index (m) values at 
each drain point 

Erosion 
Sensitivity Index 

PipeDiaToChanWi
dthRatio 

Ratio of culvert pipe diameter to channel 
width 

Stream Blocking 
Index 
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PipeDiaToChan 
WidthScore 

Hazard score calculated from ratio of 
culvert pipe diameter to channel width  

Stream Blocking 
Index 

SkewAngle Channel skew angle Stream Blocking 
Index 

SkewAngleScore Hazard score calculated from channel 
skew angle 

Stream Blocking 
Index 

SBI Stream blocking index indicating culvert 
plugging susceptibility 

Stream Blocking 
Index 

Barrier Flag representing whether the drain 
point is a fish passage barrier or not. 
0=totally blocked, 1=partially blocked, 
2=totally open 

Fish Passage 
Barrier 

 

RoadLines Table 

Field Name Description Menu Function 
GRAIPRID Unique road line segment identifier Preprocessor 
CDate Survey collection date Preprocessor 
CTime1 Survey collection time 1. This is a 4 

digit numeric field. 
Preprocessor 

CTime2 Survey collection time 2. This is a 4 
digit numeric field. 

Preprocessor 

VehicleID Survey vehicle identifier Preprocessor 
OrigSourceCode Original road line feature ID Preprocessor 
RoadNetworkID Identifier for a road network. Base 

erosion rate depends on road network 
ID 

Preprocessor 

RoadTypeID Identifier for type of the road (i.e.: 
system road, trail) 

Preprocessor 

OrigDrainID1 Original drain point identifier for side 
one of the road 

 

OrigDrainID2 Original drain point identifier for side 
two of the road 

 

GRAIPDID1 Identifier of drain point that drains side 
one of the road  

Preprocessor 

GRAIPDID2 Identifier of drain point that drains side 
two of the road 

Preprocessor 

SurfaceTypeID Identifier representing road surface 
type.  

Preprocessor 

SurfaceConditionI
D 

Identifier representing road surface 
condition 

Preprocessor 

SurfaceCoverID Identifier representing the road surface 
cover 

Preprocessor 

RoadEdge1ID Identifier for road side one edge 
information 

Preprocessor 

RoadEdge2ID Identifier for road side two edge 
information  

Preprocessor 

EdgeVegetation1I
D 

Identifier for road side one edge 
vegetation  

Preprocessor 
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EdgeVegetation2I
D 

Identifier for road side two edge 
vegetation  

Preprocessor 

EdgeConditionID
1 

Identifier for road side one edge 
condition 

Preprocessor 

EdgeConditionID
2 

Identifier for road side two edge 
condition 

Preprocessor 

FlowPath1ID Identifier for road side one flow path 
information  

Preprocessor 

FlowPath2ID Identifier for road side two flow path 
information  

Preprocessor 

FlowPathVeg1 ID Identifier for road side one flow path 
vegetation  

Preprocessor 

FlowPathVeg2 ID Identifier for road side two flow path 
vegetation  

Preprocessor 

FlowPathCond1 
ID 

Identifier for road side one flow path 
condition  

Preprocessor 

FlowPathCond2 
ID 

Identifier for road side two flow path 
condition  

Preprocessor 

FillChannelID Identifier giving road fill channel 
information 

Preprocessor 

HUCName HUC Name Preprocessor 
Miles Length of road segment (miles) Preprocessor 
Comments Additional Comments about the road 

segment 
Preprocessor 

StreamConnect1I
D 

Identifier for road side one stream 
connectivity status 

Preprocessor 

StreanConnect2ID Identifier for road side two stream 
connectivity status 

Preprocessor 

Length Length of the road segment (m) Road Segment 
Sediment 
Production 

Slope Slope of the road segment (unitless) Road Segment 
Sediment 
Production 

SedProd1 Sediment production from side one of 
the road (kg/yr) 

Road Segment 
Sediment 
Production 

SedProd2 Sediment production from side two of 
the road (kg/yr) 

Road Segment 
Sediment 
Production 

UnitSed Unit sediment production from both 
sides of the road segment (kg/m/yr) 

Road Segment 
Sediment 
Production 

TotSedProd Total sediment production from both 
sides of the road (kg/yr) 

Road Segment 
Sediment 
Production 

TotSedDel Total sediment delivered to streams 
(kg/yr) 

Road Segment 
Sediment 
Production 
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UnitTotSedDel Total unit sediment delivered to 
streams (kg/m/yr) 

Road Segment 
Sediment 
Production 

 

BroadBaseDipAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
BroadBaseDipTypeID Identifier representing Broad Base Dip type 
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
ObstructionID Identifier for the presence of an obstruction  
FillErosionID Identifier for presence of fill erosion 
BroadBaseDipConditionID Identifier for broad base dip drain point condition 
MaterialID Identifier for material found in the drain point 

 

DiffuseDrainAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
ObstructionID Identifier for the presence of an obstruction  
FillErosionID Identifier for presence of fill erosion 

 

DitchReliefAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
SizeID Identifier for the size of the drain point 
PipeLength Length of the culvert pipe used 
DitchReliefTypeID Identifier for ditch relief type 
DitchReliefConditionID Identifier for ditch relief condition 
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
FillErosionID Identifier for presence of fill erosion 
ObstructionID Identifier for the presence of an obstruction  
FlowDiversionID Identifier for the presence of flow diversion 
FlowDiffuserID Identifier for flow diffuser type  
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LeadOffAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
LeadOffConditionID Identifier for condition of lead off drain point 
ObstructionID Identifier for the presence of an obstruction  

 

NonEngAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
NonEngConditionID Identifier for condition of Non-Engineered drain 

point  
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
ObstructionID Identifier for the presence of an obstruction  
FillErosionID Identifier for presence of fill erosion 

 

StrXingAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
StrXingTypeID Identifier for stream crossing type 
PipeDimID Identifier for culvert pipe dimension 
PipeLength Culvert pipe length (feet) 
ChannelWidth Channel width (feet) 
PipeNumberID Identifier for number of pipes used 
FillDepth Fill depth (feet) 
StrXingConditionID Identifier for condition of stream crossing drain point  
FillErosionID Identifier for presence of fill erosion 
ChannelAngleID Identifier for angle between stream and stream 

crossing 
BlockTypeID Identifier for the presence and type of stream 

crossing blockage  
OutletDrop Outlet channel drop (feet) 
PoolDepth Channel pool depth (feet) 
PipeGradient Stream crossing pipe gradient in percentage 
SubstrateID Identifier for substrate material 
DebrisFlowID Identifier for the presence of a debris flow 
DiversionID Identifier for the presence and direction of channel 

diversion 
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SumpAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
SumpConditionID Identifier for condition of sump drain point  

 

WaterBarAtt Table 

Field Name Description 
GRAIPDID Drain Point identifier. Foreign key to GRAIPDID in 

DrainPoints Table 
WaterBarTypeID Identifier for water bar type 
SlopeShapeID Identifier for drain point discharge slope shape 
DischargeToID Identifier for drain point discharge feature (e.g. gully, 

forest floor)  
ObstructionID Identifier for presence of obstruction  
FillErosionID Identifier for presence of fill erosion 
WaterBarConditionID Identifier for condition of water bar crossing drain 

point 
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PREFERRED VALUE TABLES 

BlockTypeDefinitions 

BlockTypeID BlockType Description 
1 No Stream crossing not blocked (Default) 
2 Sediment Plume Stream crossing blocked by sediment 

plume 
3 Scoured road Stream crossing blocked due to scoured 

road 
4 Washed out road Stream crossing blocked due to washed 

out road 
5 Organic debris pile Stream crossing blocked by organic 

debris pile 
 

BroadBaseDipCondDefinitions 

BroadBaseDipConditionID Condition Description 
1 No Problem Default 
2 Puddles on road  
3 Wetland in ditch  
4 Saturated fill  

 

BroadBaseDipTypeDefinitions 

BroadBaseDipTypeID BroadBaseDipTypeName Description 
1 Grade Reversal Default 
2 Flat Ditch  
3 Constructed  

 

ChannelAngleDefinitions 

ChannelAngleID ChannelAngle Description 
1 < 25 degrees The flow changes direction by less than 25 

degrees when entering stream crossing 
(Default) 

2 25-45 degrees The flow changes direction by between 25 
and 45 degrees when entering stream crossing  

3 45-75 degrees The flow changes direction by between 45 
and 75 degrees when entering stream crossing 

4 > 75 degrees The flow changes direction by more than 75 
degrees when entering stream crossing 

 

DebrisFlowDefinitions 

DebrisFlowID DebrisFlow Description 
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1 No Default 
2 Yes  

 

DischargeToDefinitions 

DischargeToID DischargeTo Description 
1 Forest Floor Default 
2 Gully  
3 Ditch  
4 Landslide  
5 Wetland  
6 Stream  

 

DitchReliefCondDefinitions 

DitchReliefConditionID Condition Description 
1 0 Ditch relief drain in good condition 

(Default) 
2 1-20% Ditch relief drain 1-20% blocked 
3 20-80% Ditch relief drain 20-80% blocked 
4 80-100% Ditch relief drain 80-100% blocked 
5 Partially 

Crushed 
Ditch relief drain partially crushed 

6 Totally 
Crushed 

Ditch relief drain totally crushed 

7 Rusted 
Significantly 

Ditch relief drain significantly rusted 

8 Flows around 
pipe 

Ditch relief drain flows around the 
pipe 

 

DitchReliefTypeDefinitions 

DitchReliefTypeID DitchReliefTypeName Description 
1 CMP (Steel) Default 
2 CON (Concrete)  
3 ALM (Aluminum)  
4 ABS (Plastic)  
5 WDN (LOG)  

 

DiversionDefinitions 

DiversionID Diversion Description 
1 None Default 
2 1 Direction  
3 2 Direction  
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DrainTypeDefinitions 

DrainTypeID DrainTypeName TableName Description 
1 Broad base dip BroadBaseDipAtt Attribute table name for 

Broad Base Dip type drain 
point 

2 Diffuse drain DiffuseDrainAtt Attribute table name for 
Diffused type drain point 

3 Ditch relief DitchReliefAtt Attribute table name for 
Ditch Relief type drain 
point 

4 Lead off LeadOffAtt Attribute table name for 
Lead Off type drain point 

5 Non-engineered NonEngAtt Attribute table name for 
Non-Engineered type 
drain point 

6 Stream Crossing StrXingAtt Attribute table name for 
Stream Crossings type 
drain point 

7 Sump SumpAtt Attribute table name for 
Sump type drain point 

8 Water bar WaterBarAtt Attribute table name for 
Waterbar type drain point 

 

FillErosionDefinitions 

FillErosionID FillErosion Description 
1 No Default 
2 Yes  

 

FlowDiffuserDefinitions 

FlowDiffuserID FlowDiffuser Description 
1 None Default 
2 Half pipe fabric  
3 Fabric hose  
4 Rip rap  

 

FlowDiversionDefinitions 

FlowDiversionID FlowDiversion Description 
0 Unknown Default 
1 No  
2 Yes  
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LeadOffCondDefinitions 

LeadOffConditionID Condition Description 
1 No problem Default 
2 Gullied  
3 Not functional  
4 Excess deposition  

 

MaterialDefinitions 

MaterialID MaterialName Description 
1 Crushed  
2 Native soil Default 
3 Vegetated  
4 Paved  
5 Cinder  

 

NonEngCondDefinitions 

NonEngConditionID Condition Description 
1 Blocked ditch Default 
2 Diverted wheel track  
3 Broken berm  
4 Gully crosses road  
5 Outsloped  

 

ObstructionDefinitions 

ObstructionID Obstruction Description 
1 None Drain point not obstructed 
2 Moderate Drain point has moderate obstruction (Default) 
3 Abundant Drain point has considerable obstruction 

 

PipeDimDefinitions 

PipeDimID Dimension Description 
0 N/A Default 
1 12 Round 12 inch pipe 
2 15 Round 15 inch pipe 
3 18 Round 18 inch pipe 
4 24 Round 24 inch pipe 
5 36 Round 36 inch pipe 
6 48 Round 48 inch pipe 
7 60 Round 60 inch pipe 
8 >60 Pipe greater than 60 inches diameter 
9 13X17 Oval pipe 13 inches x 17 inches 
10 15X21 Oval pipe 15 inches x 21 inches 
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11 20X28 Oval pipe 20 inches x 28 inches 
12 24X35 Oval pipe 24 inches x 35 inches 
13 29X42 Oval pipe 29 inches x 42 inches 
14 33X49 Oval pipe 33 inches x 49 inches 
15 38X57 Oval pipe 38 inches x 57 inches 

 

PipeNumberDefinitions 

PipeNumberID PipeNumber Description 
0 N/A Default 
1 1  
2 2  
3 3  
4 >3  

 

SizeDefinitions 

SizeID DSize Description 
1 <12" Pipe size less than 12 inches 
2 12" 12 inch pipe 
3 15" 15 inch pipe 
4 18" 18 inch pipe (Default) 
5 24" 24 inch pipe 
6 >24" Pipe size greater than 24 inches 

 

SlopeShapeDefinitions 

SlopeShapeID SlopeShape Description 
1 Concave  
2 Planar  
3 Convex  

 

StreamConnectDefinitions 

StreamConnectID StreamConnection Description 
0 Unknown  
1 No Drain point discharge does not enter 

stream directly. (Default) 
2 Yes Drain point discharge enters stream 

directly 
 

StrXingCondDefinitions 

StrXingConditionID Condition Description 
1 Open and Sound Default 
2 Partially blocked  
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3 Totally blocked  
4 Partially crushed  
5 Totally crushed  
6 Rusted significantly  
7 Flows around pipe  
8 Scoured under bridge  

 

StrXingTypeDefinitions 

StrXingTypeID StrXingTypeName Description 
1 Steel culvert round Default 
2 Steel culvert oval  
3 Steel arch bottomless  
4 Plastic culvert  
5 Baffled culvert  
6 Concrete culvert  
7 Log culvert  
8 Concrete ford  
9 Natural ford  
10 Aluminum culvert  
11 Bridge  

 

SubstrateDefinitions 

SubstrateID Substrate Description 
1 Culvert Material Default 
2 Sand  
3 Gravel  
4 Boulders  
5 Bedrock  
6 Baffled  
7 Concrete  

 

SumpCondDefinitions 

SumpConditionID Condition Description 
1 No problem Default 
2 Fill saturation  
3 Puddles on road  

 

WaterBarCondDefinitions 

WaterBarConditionID Condition Description 
1 No problem Default 
2 Damaged  
3 Too small  
4 Drains inboard ditch  
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5 Wheel track damage  
 

WaterBarTypeDefinitions 

WaterBarTypeID WaterBarTypeName Description 
1 Road material Default 
2 Fabricated material  

 

EdgeConditionDefinitions 

EdgeConditionID EdgeCondition Description 
1 No problem Default 
2 Badly rilled  
3 Badly ravelling  
4 Badly slumping  
5 Bedrock  

 

EdgeVegetationDefinitions 

EdgeVegetationID EdgeVegetation Description 
1 Default Road side vegetation density is unknown 

or not specified (Default) 
2 >75% Road side vegetation density is greater 

than 75% 
3 >50% Road side vegetation density is greater 

than 50% 
4 >25% Road side vegetation density is greater 

than 25% 
5 >10% Road side vegetation density is greater 

than 10% 
6 0% Road side vegetation density is less than 

10% 
 

FillChannelDefinitions 

FillChannelID FillChannel Description 
1 0 Fill slope ends right at channel 
2 1-20 Distance from fill slope toe to channel is between 

1 and 20 feet 
3 21-50 Distance from fill slope toe to channel is between 

21 and 50 feet 
4 Above 50 Distance from fill slope toe to channel is greater 

than 50 feet (Default) 
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FlowPathCondDefinitions 

FlowPathCondID FlowPathCond Description 
1 No problem Default 
2 Gullied  
3 Buried  
4 Rutted  
5 Blocked  
6 Stream course  
7 Woody veg (%)  

 

FlowPathDefinitions 

FlowPathID FlowPath Description 
1 Ditch Default 
2 Wheel tracks  
3 Base of cut  
4 Berm  
5 Diffuse  

 

FlowPathVegDefinitions 

FlowPathVegID FlowPathVeg Description Multiplier 
1 110% Unknown or unspecified road 

side flow path vegetation 
density (Default) 

1 

2 >75% Road side flow path vegetated 
more than 75% 

0.14 

3 >50% Road side flow path vegetated 
50% to 75% 

0.14 

4 >25% Road side flow path vegetated 
25% to 50% 

0.14 

5 >10% Road side flow path vegetated 
10% to 25% 

1 

6 >0% Road side flow path vegetated 
0 to 10% 

1 

7 0% No road side flow path 
vegetation 

1 

 

RoadEdgeDefinitions 

RoadEdgeID RoadEdge Description 
1 Fill Road side feature is fill 
2 0' no ditch Road side level with terrain, no ditch 
3 0-6' Road side cut between 0 and 6 ft high (Default) 
4 6-18' Road side cut 6 to 18 ft high 
5 >18', 0% Road side cut higher than 18 ft 

 



GRAIP 1.0  Geomorphologic Road Analysis and Inventory Package 

Tutorial Manual  66 

RoadNetworkDefinitions 

RoadNetworkID RoadNetwork Description BaseRate 
1 Default Default Base rate from Luce 

and Black, 1999 
79 

2 Custom Custom base rate for a specific 
study area 

79 

 

RoadTypeDefinitions 

RoadTypeID RoadType Description 
1 System road Default 
2 High clearance road  

 

SurfaceConditionDefinitions 

SurfaceConditionID SurfaceCondition Description 
1 Good  
2 Rilled/eroded  
3 Washboard  
4 Rutted  
5 Rocky  

 

SurfaceCoverDefinitions 

SurfaceCoverID SurfaceCover Description 
1 >75% Road surface is vegetated more than 75% 

(Default) 
2 >50% Road surface is vegetated between 50 and 75% 
3 >25% Road surface is vegetated between 25 and 50% 
4 >10% Road surface is vegetated between 10 and 25% 
5 0% Road surface is vegetated between 0 and 10% 

 

SurfaceTypeDefinitions 

SurfaceTypeID SurfaceType Description Multiplier 
1 Default Default 1 
2 Crushed rock  1 
3 Native  5 
4 Paved  0.2 
5 Herbaceous Veg  1 
6 Brush  1 
7 Trees > 4 in Dia  1 
8 Cinder  1 
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VehicleDefinitions 

VehicleID Vehicle Description 
1 Survey Truck  

 

UTILITY TABLES 

FieldMatches 

ID AttTableID DBField DBFField 
1 0 SurfaceTypeID SURF_TYPE 
2 0 SurfaceConditionID SURF_COND 
3 0 RoadTypeID ROAD_TYPE 
4 0 RoadEdge1ID RD_EDGE_1 
5 0 RoadEdge2ID RD_EDGE_2 
6 0 EdgeVegetation1ID EDGE_VEG_1 
7 0 EdgeVegetation2ID EDGE_VEG_2 
8 0 EdgeCondition1ID EDG_CND_1 
9 0 EdgeCondition2ID EDG_CND_2 
10 0 FlowPath1ID FLOW_PATH1 
11 0 FlowPath2ID FLOW_PATH2 
12 0 FlowPathVeg1ID FLWPTH_VG1 
13 0 FlowPathVeg2ID FLWPTH_VG2 
14 0 FlowPathCond1ID FLWPTHCND1 
15 0 FlowPathCond2ID FLWPTHCND2 
16 0 FillChannelID FILL_CHAN 
17 0 SurfaceCoverID SURF_COV 
18 0 CDate CDATE 
19 0 CTime1 CTIME1 
20 0 CTime2 CTIME2 
21 0 VehicleID VEHICLE 
22 1 Comments COMMENT 
23 1 CDate CDATE 
24 1 CTime CTIME 
25 1 VehicleID VEHICLE 
26 1 StreamConnectID STREAM_CON 
27 1 BroadBaseDipTypeID TYPE 
28 1 SlopeShapeID SLOPE_SHAP 
29 1 DischargeToID DISCHRG_TO 
30 1 ObstructionID OBSTRUCT 
31 1 FillErosionID FILL_EROS 
32 1 BroadBaseDipConditionID CONDIT 
33 1 MaterialID MATERIAL 
34 1 Comments COMMENT 
35 2 CDate CDATE 
36 2 CTime CTIME 
37 2 VehicleID VEHICLE 
38 2 StreamConnectID STREAM_CON 
39 2 SlopeShapeID SLOPE_SHAP 
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40 2 DischargeToID DISCHRG_TO 
41 2 ObstructionID OBSTRUCT 
42 2 FillErosionID FILL_EROS 
43 2 Comments COMMENT 
44 3 CDate CDATE 
45 3 CTime CTIME 
46 3 VehicleID VEHICLE 
47 3 StreamConnectID STREAM_CON 
48 3 SizeID SIZE 
49 3 PipeLength PIPE_LEN 
50 3 DitchReliefTypeID TYPE 
51 3 DitchReliefConditionID CONDIT 
52 3 SlopeShapeID SLOPE_SHAP 
53 3 DischargeToID DISCHRG_TO 
54 3 FillErosionID FILL_EROS 
55 3 ObstructionID OBSTRUCT 
56 3 FlowDiversionID FLOW_DIVER 
57 3 FlowDiffuserID FLOW_DIFFU 
58 3 Comments COMMENT 
59 4 CDate Date 
60 4 CTime Time 
61 4 VehicleID Vehicle 
62 4 StreamConnectID STREAM_CON 
63 4 SlopeShapeID SLOPE_SHAP 
64 4 DischargeToID DISCHRG_TO 
65 4 LeadOffConditionID CONDIT 
66 4 ObstructionID OBSTRUCT 
67 4 Comments COMMENT 
68 5 CDate CDATE 
69 5 CTime CTIME 
70 5 VehicleID VEHICLE 
71 5 StreamConnectID STREAM_CON 
72 5 SlopeShapeID SLOPE_SHAP 
73 5 DischargeToID DISCHRG_TO 
74 5 ObstructionID OBSTRUCT 
75 5 FillErosionID FILL_EROS 
76 5 NonEngConditionID CONDIT 
77 5 Comments COMMENT 
78 6 CDate CDATE 
79 6 CTime CTIME 
80 6 VehicleID VEHICLE 
81 6 StrXingTypeID TYPE 
82 6 PipeDimID R_PIPE_DIA 
83 6 PipeDimID(Oval) OVAL_PIPE 
84 6 PipeLength PIPE_LEN 
85 6 ChannelWidth CHAN_WDTH 
86 6 PipeNumberID PIPE_NUM 
87 6 FillDepth FILL_DEPTH 
88 6 StrXingConditionID CONDIT 
89 6 ChannelAngleID CHAN_ANGL 
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90 6 BlockTypeID BLOCK_TYP 
91 6 OutletDrop OUTLET_DRP 
92 6 PoolDepth PL_DEPTH 
93 6 PipeGradient PIPE_GRADE 
94 6 SubstrateID SUBSTRATE 
95 6 DebrisFlowID DEBRIS_FLW 
96 6 FillErosionID FILL_EROSN 
97 6 DiversionID DIVERSION 
98 6 Comments COMMENT 
99 7 CDate CDATE 
100 7 CTime CTIME 
101 7 VehicleID VEHICLE 
102 7 SumpConditionID CONDIT 
103 7 Comments COMMENT 
104 8 Cdate Date 
105 8 Ctime Time 
106 8 VehicleID Vehicle 
107 8 StreamConnectID STREAM_CON 
108 8 WaterBarTypeID TYPE 
109 8 SlopeShapeID SLOPE_SHAP 
110 8 DischargeToID DISCHRG_TO 
111 8 ObstructionID OBSTRUCT 
112 8 FillErosionID FILL_EROS 
113 8 WaterBarConditionID CONDIT 
114 8 Comments COMMENT 

 

DPErrorLog Table Structure 

Field Name Description 
Index Unique identifier (Auto number in MS Access) 
GRAIPDID Identifier from DrainPoints table 
DrainType Type of the drain point (Eg: Broad Base Dip) 
ErrorMessage Validation error message 
ActionTaken Action taken to correct error 

 

RDErrorLog Table Structure 

Field Name Description 
Index Unique identifier (Auto number in MS Access) 
GRAIPRID Identifier from RoadLines table 
RoadType Type of road line (Eg: System road) 
ErrorMessage Validation error message 
ActionTaken Action taken to correct error 

 

MetaData 

ID IDFieldName DefinitionTable 
1 DrainTypeID DrainTypeDefinitions 
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2 VehicleID VehicleDefinitions 
3 StreamConnectID StreamConnectDefinitions 
4 BroadBaseDipTypeID BroadBaseDipTypeDefinitions 
5 SlopeShapeID SlopeShapeDefinitions 
6 DischargeToID DischargeToDefinitions 
7 ObstructionID ObstructionDefinitions 
8 FillErosionID FillErosionDefinitions 
9 BroadBaseDipConditionID BroadBaseDipCondDefinitions 
10 MaterialID MaterialDefinitions 
11 DitchReliefTypeID DitchReliefTypeDefinitions 
12 DitchReliefConditionID DitchReliefCondDefinitions 
13 FlowDiversionID FlowDiversionDefinitions 
14 FlowDiffuserID FlowDiffuseDefinitions 
15 LeadOffConditionID LeadOffCondDefinitions 
16 NonEngConditionID NonEngCondDefinitions 
17 StrXingTypeID StrXingTypeDefinitions 
18 PipeDimID PipeDimDefinitions 
19 PipeNumberID PipeNumberDefinitions 
20 StrXingConditionID StrXingCondDefinitions 
21 ChannelAngleID ChannelAngleDefinitions 
22 BlockTypeID BlockTypeDefinitions 
23 SubstrateID SubstrateDefinitions 
24 DebrisFlowID DebrisFlowDefinitions 
25 DiversionID DiversionDefinitions 
26 SumpConditionID SumpCondDefinitions 
27 WaterBarTypeID WaterBarTypeDefinitions 
28 WaterBarConditionID WaterBarCondDefinitions 
29 RoadNetworkID RoadNetworkDefinitions 
30 RoadTypeID RoadTypeDefinitions 
31 SurfaceTypeID SurfaceTypeDefinitions 
32 SurfaceConditionID SurfaceConditionDefinitions 
33 SurfaceCoverID SurfaceCoverDefinitions 
34 RoadEdge1ID RoadEdgeDefinitions 
35 RoadEdge2ID RoadEdgeDefinitions 
36 EdgeVegetation1ID EdgeVegetationDefinitions 
37 EdgeVegetation2ID EdgeVegetationDefinitions 
38 EdgeCondition1ID EdgeConditionDefinitions 
39 EdgeCondition2ID EdgeConditionDefinitions 
40 FlowPathVeg1ID FlowPathVegDefinitions 
41 FlowPathVeg2ID FlowPathVegDefinitions 
42 FlowPath1ID FlowPathDefinitions 
43 FlowPath2ID FlowPathDefinitions 
44 FlowPathCond1ID FlowPathCondDefinitions 
45 FlowPathCond2ID FlowPathCondDefinitions 
46 FillChannelID FillChannelDefinitions 
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TAUDEM STREAM NETWORK SHAPEFILE ATTRIBUTE TABLE 

The TauDEM stream network delineation function creates a stream network shapefile 
with the following attributes: 

Field Description 
LINKNO Link Number. A unique number associated with each link 

(segment of channel between junctions) 
DSLINKNO Link Number of the downstream link. -1 indicates that this 

does not exist. 
USLINKNO1 Link Number of first upstream link 
USLINKNO2 Link Number of second upstream link. 
DSNODEID Node identifier for node at downstream end of stream reach. 

This identifier corresponds to the "id" attribute from the 
Outlets shapefile used to designate nodes. 

Order Strahler Stream Order 
Length Length of the link 
Magnitude Shreve Magnitude of the link. This is the total number of 

sources upstream 
DS_Cont_Ar Drainage area at the downstream end of the link. Generally 

this is one grid cell upstream of the downstream end because 
the drainage area at the downstream end grid cell includes 
the area of the stream being joined. 

Drop Drop in elevation from the start to the end of the link 
Slope Average slope of the link (computed as drop/length) 
Straight_L Straight line distance from the start to the end of the link 
US_Cont_Ar Drainage area at the upstream end of the link 
WSNO Watershed number. Cross reference to the *w.shp and *w 

grid files giving the identification number of the watershed 
draining directly to the link. 

DOUT_END Distance to the outlet from the downstream end of the link 
DOUT_START Distance to the outlet from the upstream end of the link 
DOUT_MID Distance to the outlet from the midpoint of the link 
 

The following attributes that record sediment input to the stream network and habitat 
patch clusters are added to the stream network shapefile by the GRAIP toolbar: 

Field Description Menu Function 
SedAccum Accumulated upstream sediment 

load from road surface at the 
downstream end of each stream 
segment (kg/yr) 

Upstream Stream 
Sediment Input 

SedDir Direct sediment input from road 
surface to each stream segment 
(kg/yr) 

Direct Stream 
Sediment Input 
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SpecSed Specific sediment accumulation to 
each stream segment defined as 
accumulated upstream sediment 
production divided by upstream 
contributing area at the 
downstream end of each stream 
segment (Mg/yr/m

2
) 

Upstream Stream 
Sediment Input 

SpecSedDir Direct specific sediment input to 
each stream segment divided by 
the direct area draining to each 
stream segment (Mg/yr/m

2
) 

Direct Stream 
Sediment Input 

HabPatchID A unique identifier for each 
contiguous habitat cluster as 
demarcated by fish passage barrier 

Habitat Segmentation 
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GRAIP SOURCECODE FOLDER ORGANIZATION 

 

TOOLBARCOMDLL 

Source code for C++ .dll that is used by the GRAIP Toolbar. 

VS 6 workspace: COMDLL\rsamCOMDLL.dsw 

Release config compiles to: COMDLL\ReleaseMinDependency\graipCOMDLL.dll 

Debug config compiles to: C:\Program Files\GRAIP\graipCOMDLL.dll 

Depends on: 

A. RasterIO.dll (for execution) 

B. RasterIO.lib (for compiling) 

C. ShapeCode that is included in this folder 

CONSOLIDATESHP 

Source code for C++ .dll that is used by the GRAIP Preprocessor. 

VS 6 workspace: consolidateShp.dsw 

Release config compiles to: ReleaseMinSize\consolidateShp.dll 

Debug config compiles to: C:\Program Files\GRAIP\consolidateShp.dll 

Depends on: 

A. ShapeLib that is included in this folder 

DATABASEPREPROCESSOR 

Source code for VB executable that is the GRAIP Preprocessor. 

VB 6 project: GRAIPPreprocessor.vbp 

Compiles to: C:\Program Files\GRAIP\DBPreprocessor.exe 

Depends on: 

A. consolidateShp.dll 

B. MS Access database file GRAIP DB\GRAIP.mdb to run 

ARCTOOLBAR 

Source code for VB .dll for ArcMap Plug-in. 

VB6 project: agRSAM.vbp 

Compiles to: C:\Program Files\GRAIP\agGRAIP.dll 

Depends on: 

A. tkTauDEM.dll 
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B. ToolBarComDLL.dll 

C. sinmapCOMDLL.dll in C:\Program Files\TauDEM 

D. C:\Program Files\GRAIP 

E. C:\Program Files\SINMAP 

F. Pro Essentials 

INSTALLATION 

Installshield project for GRAIP. This gets files from ReleaseFiles that has the same 
structure as Program Files\GRAIP. Pro essentials is not distributed with GRAIP 
because it is part of SINMAP and GRAIP depends on SINMAP. 

RELEASEFILES 

Contains release files that Installshield uses. 

RELEASESETUP 

Contains output from installshield for distribution. 

DOCUMENTATION 

Contains the wordprocessing and image files for the documentation. 
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GRAIP 1.0 RELEASE NOTES 

 

Issue Resolution 
If you get the following error message: 
Run-time error '-2147467259 
(80004005)': 
[Microsoft][ODBC Driver Manager] 
Data source name not found and no 
default driver specified 
 

You need to create an ODBC Data Source 
called “dBASE Files” that uses the 
ODBC driver “Microsoft dBase Driver 
(*.dbf)”. 
 

 

Versions 

Number Release Date Notes 

1.0.0 5/24/07 

1.0.1 6/4/07 

1.0.2 7/6/07 

1.0.3 7/10/07 

1.0.4 8/14/07 Link between Roadlines and Drainpoints 
created from CDate, CTime and Vehicle fields 

1.0.5 9/14/07 - If near match is found for Add Value, reassign 
is now initially selected. 

  - Added alpha and beta parameters to the Filter 
Stream Crossing Function. 

  - Added Slope to the Roadlines table. 

  - Added alpha parameter to the LS Plot 
Function. 

  - Clarified the meaning of Possible Passage. 

1.0.6 2/29/08 - Added ability to have multiple input shapefiles 
of the same type. 

  - Expanded the length of several text fields in 
the database. 

  - Fixed the preprocessor so that the file info is 
saved when an additional file is added to an 
existing project.    

  - Delete Drainpoints and Roadlines index files 
when the shapefiles are deleted in the 
preprocessor so that expired index files don’t 
cause drain points and road line segments to 
disappear in ArcGIS.  

1.0.7 3/9/09 - Fixed Elength calculation. 
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  - Fixed RemoveGrid function to only scan for 
GRID files rather than all raster dataset files.  
This prevents errors when there is another file 
with a raster dataset extension in the workspace. 

  - Corrected a few typos in the manual 

1.0.8 3/20/10 - Fixed bug in the writing of parameters file for 
combined stability index function.  The program 
should no longer overwrite parameters with the 
default parameters after they have been edited 

1.0.9 1/2/2014 - Road sediment production function is now 
using elevation values at the start and end points 
avoiding the ESRI range function.  This resolves 
the errors associated with the ESRI summarize 
by zones function giving a poor estimate of 
length time slope product.   

  - Upstream stream sediment input function is 
now using contributing area rather than 
elevation to determine the grid cell from the 
sediment accumulation grid (sac) to use for 
sediment load for each stream segment.  In 
addition, it now uses the sediment accumulation 
one grid cell upstream from a junction for 
stream sediment accumulation.  This resolves 
the issues of load from the downstream segment 
being incorrectly assigned to inflowing stream 
segments giving the appearance of sediment 
load creeping up streams.   

  - Upstream stream sediment input (specific 
sediment):  The computation of specific 
sediment was omitting cell area.  This has been 
corrected and the code changed to include the 
conversion factors required to report the results 
in Mg/yr/km

2
. 

  - Direct stream sediment input:  The logic for 
computation of direct stream sediment input has 
been changed to use sediment accumulation 
values computed for the stream network rather 
than grid values.  This resolves an error that was 
occurring due to omitting the sediment 
contributions directly at stream junctions.   

  - The combined stability index function has 
been changed to include on its interface a series 
of check boxes identifying the drain points to be 
used in combined stability index evaluation.  
Prior to this change runoff from all drain points 
were always included in the calculation.  A new 
column "CCSI" has been added to the 
DrainTypeDefinitions table to record the 
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selection of drain types used in computation of 
combined stability index. User selection of drain 
types using the Combined Stability Index screen 
is saved to the database.   

  - A new function to determine distance to 
stream from drain points by looking up values 
calculated using TauDEM to has been added. 

  - The resample DEM function has been changed 
to use bilinear interpolation as opposed to cubic 
interpolation. 

  - Corrected a number of Preprocessor errors to 
improve error trapping and discrepancy 
identification in the Preprocessor to prevent 
entry of content into the database with 
inconsistent controlled vocabulary references. 

  - Generalized initialization in the Preprocessor 
to read attribute table names from 
DrainTypeDefinitions table rather than have 
them hardcoded. 

  - Fixed the database browse dialog so that it can 
more easily be used to select an existing start 
database. 

  - Added libraries to the installer for 
compatibility with Windows 7. 

  - Removed unnecessary Toolbar dependence 
upon SINMAP DLL 

  - Changed some hardcoded table names to be 
consistent with new database schema 
(PipeGrade was PipeGradient) 

  - Corrected the error in LSPlot incorrectly 
symbolizing points. 

  - Added the capability to the Stream Blocking 
Index function to control the stream crossing 
types for which SBI is evaluated.  This is now 
controlled through a column (CSBI) in 
StrXingTypeDefinitions that indicates for each 
stream crossing type whether its SBI should be 
evaluated (or left at the initialization value of 0). 

  - Added error trapping to Toolbar to produce 
more explanatory errors when it encounters 
missing required information. 

  - Generalized the code for determining pipe 
diameters in Stream Blocking Index function to 
use diameter values from the controlled 
vocabulary table rather than infer pipe diameters 
from the controlled vocabulary identifier, thus 
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resolving errors that occurred due to the 
controlled vocabulary changing. 

  - Added error trapping to Fish Habitat 
Segmentation to trap for stream network 
shapefile name being too long for DBF database 
utility advising user to shorten name to run the 
function.   

  - Restructured recursion logic or Fish Habitat 
Segmentation to avoid opening a new database 
(ADODB) connection for each link that resulted 
in an error due to exceeding an allowable limit 
for large networks.  

1.0.10 6/25/2014 - graipCOMDLL.dll code was modified not to 
hold all elevation data in memory rather read the 
elevation data on a per grid basis in order to 
accommodate large DEMS in Road Surface 
Erosion calculation.  

 

  - graipCOMDLL.dll code was modified to 
calculate road segment length to replace VB 
code that used to calculate length using ArcGIS 
library function. This code change was 
necessary to make the road sediment production 
function to work in Arc10.  

 


