Purpose
The purpose of this exercise is to illustrate watershed and stream network delineation based on digital elevation models using the Hydrology tools in ArcGIS and online services for Hydrology and Hydrologic data. In this exercise, you will select a stream gage location and use online tools to delineate the watershed draining to the gage. National Hydrography and Digital Elevation Model data will be retrieved for this area (Logan River Basin) from online services. You will then perform drainage analysis on a terrain model for this area. The Hydrology tools are used to derive several data sets that collectively describe the drainage patterns of the basin. Geoprocessing analysis is performed to fill sinks and generate data on flow direction, flow accumulation, streams, stream segments, and watersheds. These data are then used to develop a vector representation of catchments and drainage lines from selected points. This exercise shows how detailed information on the connectivity of the landscape and watersheds can be developed starting from raw digital elevation data, and that this enriched information can be used to compute watershed attributes commonly used in hydrologic and water resources analyses.

Learning objectives
• Do an online watershed delineation and then extract the data for that watershed to perform a more detailed analysis.
• Identify and properly execute the sequence of Hydrology tools required to delineate streams, catchments and watersheds from a DEM.
• Evaluate and interpret drainage area and stream length properties from Terrain Analysis results.

Computer and Data Requirements
To carry out this exercise, you need to have a computer which runs ArcGIS Pro and includes the Spatial Analyst extension. No data is required to start this exercise. All the necessary data will be extracted from ArcGIS.com services. To use these services you need an ArcGIS.com account that has been linked to an ArcGIS license.

The exercise is divided into the following activities that each comprise a sequence of steps

1. Online Watershed Delineation and Data Retrieval.
2. Hydrologic Terrain Analysis
Before we start
The USGS NWIS website for the Logan River:
http://waterdata.usgs.gov/nwis/inventory?agency_code=USGS&site_no=10109000 gives the following
information about the Logan River Stream Site.

**USGS 10109000 LOGAN RIVER ABOVE STATE DAM, NEAR LOGAN, UT**

![Stream Site](image)

Note the Latitude, Longitude and geographic coordinate system (NAD27). Note also the drainage Area.

Compute the latitude and longitude in decimal degrees in an Excel Spreadsheet and save it.

<table>
<thead>
<tr>
<th>SiteID</th>
<th>LatDeg</th>
<th>LatMin</th>
<th>LatSec</th>
<th>LongDeg</th>
<th>LongMin</th>
<th>LongSec</th>
<th>LatDD</th>
<th>LongDD</th>
</tr>
</thead>
<tbody>
<tr>
<td>10109000</td>
<td>41</td>
<td>44</td>
<td>36</td>
<td>111</td>
<td>46</td>
<td>55</td>
<td>41.74333</td>
<td>-111.78194</td>
</tr>
</tbody>
</table>

Online Watershed Delineation and Data Retrieval

1. **Watershed Draining to a Stream Gage & Extracting a Digital Elevation Model**
   In this section we do the following
   
   - Create a point feature at the outlet of the Logan River Watershed
   - Use the online Ready-To-Use Tools -> Hydrology -> Watershed tool to delineate the Logan River Basin
   - Create a 1 km buffer around the Logan River Basin
   - Extract the DEM for the Logan River basin within this buffer from the NED30m DEM in the elevation.arcgis.com online data service.

Results are saved in the project geodatabase in a Basemap feature class that is created to have the **North_America_Albers_Equal_Area_Conic** coordinate system, which is the coordinate system of NED30m DEM, and chosen to standardize on in this exercise for consistency with this DEM.

Open ArcGIS Pro and create a new map project by clicking on the **Map.aptx** project template (I named it Ex4_Project). This should open with the **Topographic** basemap. (If the basemap is not automatically Topographic, select the Topographic basemap).
Click on the icon to **Add Data** and add the sheet from the spreadsheet with latitude and longitude of the Logan River Stream Gage.

Right click on this spreadsheet layer and select **Display XY data**.

![Image of spreadsheet layer options]

This should open the Make XY Event Layer Geoprocessing tool. Set the X and Y fields to the spreadsheet columns with decimal degrees. Recall that the USGS NWIS website indicated a NAD27 coordinate system. Click **Select Coordinate System** to set the coordinate system.
Locate **Geographic Coordinate Systems → North America → NAD1927** in the Coordinate System window and click OK.
Click **Run** to Make XY Event Layer data. A dot should appear on your map showing you where the Logan River stream site is.
Zoom in on this to get a sense for the topography near Logan. I also changed the symbology of the point to make it easier to see.

In the Geoprocessing pane under Portal expand Ready-To-Use Tools to locate and click on the Watershed tool.
In the Watershed tool set the Input Points to be the layer from your spreadsheet (Sheet1$ _Layer). Set Data Source Resolution to FINEST. Leave all other settings at their defaults and click Run.
When the tool completes you should see the message Watershed completed successfully. You should also see Output Watershed that has been delineated using the online watershed delineation service added to your map. Notice that there is also an Output Snapped Points feature class that contains the outlet point "snapped" or moved to be on the streams.

Zoom to layer Output Watershed. Wow, just like that you delineated the stream network of the Logan River. If you like, change the symbology to be more appealing. If you adjust color properties, you can get the watershed to be transparent.

Now let's get the digital elevation model for this area. We will use an ArcGIS Server here. Information about ArcGIS Online ready-to-use services is available at http://pro.arcgis.com/en/pro-app/help/projects/connect-to-a-gis-server.htm

Under the Insert tab, under Connections, click on New ArcGIS Server
Enter the Server URL http://elevation.arcgis.com/arcgis. Your ArcGIS.com user name and password should not be necessary as you are logged into ArcGIS Pro.

Click OK. You should see arcgis on elevation.arcgis.com displayed in your Catalog tab under Servers.

In elevation.arcgis.com NED30m is the USGS National Elevation Dataset digital elevation model. Drag and drop this onto your map to add this data.
After processing for a while you should see the NED DEM in your map. The initial appearance is rather dark, but you can use Symbology to change the color scheme.

In the Catalog pane, navigate to your Ex4_Project.gdb geodatabase (automatically created when you create a new ArcGIS Pro project). Note that this has in it the WatershedArea and SnappedPoints feature classes from the watershed delineation. Note that the feature class has the name WatershedArea, while the layer label is Output Watershed. In this geodatabase select **New/Feature Dataset** to create a feature dataset to hold our work.
Set the name to **Basemap**.

For the coordinate system select NED30m in the Coordinate System drop down.

This selects the coordinate system of the NED30m DEM layer. Notice that after you have selected this the Coordinate system is displayed as **North_America_Albers_Equal_Area_Conic**, the coordinate system of NED30m.
Click Run. Now you have a feature dataset Basemap in your project geodatabase.

Right click on Sheet1$_Layer (the XY events layer from the gage site spreadsheet) and select Data -> Export Features.

In the Geoprocessing Copy Features tool that opens, set the Output feature class to Gage in the Basemap feature dataset and click Save. Click Run in the Geoprocessing pane to copy these features.
This serves to project the geographic coordinates of this site feature class to the North America Albers coordinate system of the Basemap feature dataset, and also to make it a permanent feature class. Remove the spreadsheet and XY Events layer (Sheet1$_Layer).

Similarly use Export Features with the Output Watershed layer to copy it into the Basemap feature dataset with name "Basin".
This serves to project the geographic coordinates of this feature class to the North America Albers coordinate system of the Basemap feature dataset. Remove the SnappedPoints and Outlet Watershed layers. This copying to a single feature dataset serves to project the data to a consistent coordinate system and collect it together in one place in an organized way. It is strictly not necessary for the software, but is a good habit of organization for users.

Now let's extract and analyze the DEM for this basin. We use a buffer to select an area slightly larger than the basin to avoid edge effects. Go to the Geoprocessing panel. Search for the **Buffer (Analysis)** tool (in the geoprocessing toolbox).

Set the inputs as follows, and run:
This produces a feature class BasinBuffer that buffers our basin by 1 km.

Next search for the **Extract by Mask (Spatial Analyst)** tool and set the inputs as follows, saving the output raster in `Ex4_project.gdb\dem`. Note that the DEM is stored at the top level in the geodatabase because a raster cannot be stored in a feature dataset.

The result is a DEM just over the buffered area.

Remove NED30m. We do not need it anymore, and save your project.
Let’s explore the ArcGIS Pro functionality that allows you to create your own color schemes to symbolize this. To create a new color scheme, first navigate to the Project tab in the Catalog pane and select Styles/New Style.

Give your new style a name and save in your project folder, to make sure the color style stays with the map (in case you move your data around).

Right-click to manage your new style, and select New Item/Color Scheme from the Home tab with the Catalog panel.
Click on New Item -. Color Scheme.

Click on the properties tab on the bottom of the screen. Change the initial green color to a good high-elevation color (I’ve chosen brown), and proceed to change the red color to a nice low-elevation color (perhaps a blue, for water). To change the red default, make sure you select the small knob below the color bar.
Click **Apply** once you’ve selected a color scheme you like.

Switch back to the Map View in the central pane and navigate back to your symbology selection for your DEM, and select the color scheme you've just created.
Feel free to adjust the Stretch type and Gamma values used for the stretch distribution, in order to improve the display of your map. Being able to add your own color schemes is extremely powerful, and is very exciting! Have fun with this section! Here’s what my map ended up looking like:

Save your project for good measure.

Zoom right in near the outlet.
Note that the watershed boundary has a stair step shape as it is based on DEM grid cells but that these are skewed relative to the map display. This is because the coordinate system of the DEM underlying the watershed delineation service is different from the Map coordinate system data frame. Let’s re-orient the Map to the coordinate system of the DEM. Right click on **Map ➔ Properties**

Select the **Coordinate System** tab and scroll to the top. Under Layers select North_America_Albers_Equal_Area Conic and click OK.
The Map data frame should adjust so the edges are not skewed. Examine the Properties -> Source -> Raster information for the DEM to identify the number of columns and rows and other raster information.

To turn in. The number of columns and rows, grid cell size, minimum and maximum elevation values in the Logan River Basin DEM (just named dem above).

2. National Hydrography Data Service (NHDPlusV2)
In this section we extract the NHDPlus stream network for the Logan River Basin from the landscape1.arcgis.com online data service.

Add another New ArcGIS Server connection: http://landscape1.arcgis.com/arcgis as you did before for elevation services.

From the landscape1 services, add USA_NHDPlusV2_1_Flat service layer to see the NHDPlus streams. You may need to expand the display to maximum extent and zoom in for the streams to appear. You may also need to unselect some of the layers (e.g. Sinks) to clean up your map. Note that the GageSnap point seems to be closer to this NHDPlus streamline.
Under “Tools” in the Landscape 1 service, use “**Extract Landscape Source Data**” (this may take a long while to load; be patient) and choose **NHDPlus V2 Flowlines** as the Landscape Layer and **Basin** as the study area.

Run the tool (this also takes quite a while).
Navigate to the Catalog pane and open the Geoprocessing History folder; this folder contains all information for each time you run a geoprocessing tool. If you open an item in this list, the geoprocessing tool will open up with the same parameter settings you used previously.

In the Geoprocessing History, hover over the Extract Landscape Source Data tool and when a window pops open, click on the pop out symbol.

Then click on the filename next to Output file to open the zip file that this tool wrote into temporary scratch space in your AppData folder.
Drag the Landscape.gdb folder in this zip file into your Exercise 4 folder. (Note that you can also go to this directory directly in your PC by typing the address directly into the top of the Windows Explorer, or viewing hidden folders and navigating there.)

In the ArcGIS Pro Catalog pane, navigate to Folders/Ex4_project and refresh the folder.
The new Landscape.gdb geodatabase should appear. Right-click and **Add to Project**, and you should see the Landscape.gdb database appear in your Databases section.

Expand the contents of Landscape.gdb. Drag NHDPlusV2 onto the map.

You should now see the extracted NHDPlusV2 features on your map view.
Right-click on NHDPlusV2 and select Data -> Export Features.

Set the Output Location to Ex4_project.gdb\Basemap and Output Feature Class to NHDPlusV2, and run.

This serves to move the NHDPlusV2 features into our Basemap feature class (converting the projection to be North_America_Albers_Equal_Area_Conic consistent with the rest of our data).

Symbolize NHDPlusV2 from Ex4_project.gdb using gage adjusted flow E (Q0001E) to give a flow map.

In the Symbology panel, select Graduated Symbols and Q0001E for the field.
Click on Template and set the color, and apply.

Turn off or remove the NHDPlusv2 service and the version of NHDPlusv2 in Landscape.gdb. This NHDPlusV2 feature class in your Basemap feature dataset is now a local set of NHDPlus streamlines for the Logan River Basin in the same coordinate system as your other data.
3. Main Stream Properties
In this section we do the following

- Use ArcGIS pro query functionality to select the Logan River main stream
- Use Summary Statistics tool to tabulate stream length
- Use stream length and area data to calculate drainage density and average hillslope length
- Extract USA_NHD_HighRes stream network from landscape1.arcgis.com use it to evaluate drainage density.

To identify the main stem of the Logan River and determine some of its properties open the Select By Attributes geoprocessing tool in the Map tab.

Click and configure a query to select where GNIS_NAME is Equal to Logan River. Click

- Field
- Values
- GNIS_NAME is Equal to Logan River
- Add
Click **Run** in the geoprocessing tool.

The Logan River main stream should be selected.

Right click **NHDPlusV2** layer and select **Data ➔ Export Features** and save the selected features as **LoganMain** in the **Logan.gdb\Basemap** feature dataset.
This is a feature representing just the Logan River. Once the LoganMain Feature Class has been written you should clear selection to remove selection from the map view.

Let’s examine the length of LoganMain. Open the attribute table of LoganMain. Note that there are multiple columns that give length. LENGTHKM is length in km from the NHD. shape_Length is the far right column and is the length evaluated by ArcGIS when the data was loaded into the geodatabase. All geodatabase features have geometry measures (e.g. length or area). The units of shape_Length are the units of the feature dataset coordinate system, which are meters in this case. You should note consistency between LENGTHKM and shape_Length once units are converted.

Right click on the column header Shape_Length of the far right column and select Summarize.

Add the fields LENGTHKM and shape_Length and the statistic type SUM. Note the name of the output table. Make sure that the Case field is blank and run.
Open the resultant statistics table that was output:

<table>
<thead>
<tr>
<th>OBJECTID</th>
<th>FREQUENCY</th>
<th>SUM_lengthkm</th>
<th>SUM_shape_length</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>47</td>
<td>52.648</td>
<td>53109.68352</td>
</tr>
</tbody>
</table>

Note the values of Sum. These are the length of LoganMain (the Logan River main stream) from the two length fields. Note that they should be numerically close once the shape_length is converted to km. They differ due to different approximations and coordinate systems being used here, and by NHDPlus.

Similarly, create a statistical summary of the NHDPlusV2 feature class to determine the total length of streams in the Logan River Basin.

Lastly, open the attribute table for Basin and look for the far right column Shape_Area. This is the Basin area in m². Calculate the drainage density for the Logan River as \( \frac{\text{Total Channel Length}}{\text{Basin Area}} \).

You might have noticed that landscape1.arcgis.com also includes a dataset USA_NHD_HighRes. This is the high resolution stream layer from 1:24,000 US topographic maps. Use a similar procedure to what was done above to add this to your map. You will need to zoom in to a scale where these stream appear to see them. Note that each map layer has a visibility range that is part of its properties. Right click on, and select Properties for USA_NHD_HighRes.

Note that this layer is set to not show the layer beyond 1:150,000 scale. For a web service based layer you cannot adjust this, but for your own layers you can set this.

Use the Extract Landscape Source Data tool to extract this dataset (NHD High Resolution – Flowlines) just for the Logan Basin, and add it to the Ex4_project.gdb Basemap feature class (to get it into the same coordinate system). Note that the zip file produced by the Landscape Source Data tool uses the name Landscape.gdb for its geodatabase in both cases so you will need to rename this or put it in a different
folder to work with it. Determine the total length of streams from NHD_HighRes and compute the drainage density for the Logan River Basin using NHD_HighRes flowlines.

Note that NHDPlus is derived from what is referred to as the medium resolution national hydrography dataset and is generally used for coarser scale work. NHD_HighRes is the most detailed data available and is used for very detailed work.

At this point you have extracted all the data you need locally and are ready to begin Hydrologic Terrain Analysis.

To turn in. Prepare a layout showing the topography, Basin Outline, NHDPlusV2 streams, and Logan River Main stem stream for the Logan River Basin. Include a scale bar and North arrow and appropriate title, labeling and legend so that the map is self-describing.

To turn in. Report the main stream length, total stream length, basin area and drainage density for the Logan River Basin as determined from NHDPlus flowlines. Report the total stream length and drainage density for the Logan River Basin as determined from NHD_HighRes flowlines. Comment on the differences. For each drainage density value calculate the average overland flow distance water originating on a hillslope has to travel before reaching a stream. [Hint: Refer to slide 16 from ExtendedTerrainAnalysis.pptx in lecture 10.] Comment on the differences.
Hydrologic Terrain Analysis
This activity will guide you through the initial hydrologic terrain analysis steps of Fill Pits, calculate Flow Direction, and calculate Flow Accumulation (steps 1 to 3). The resulting flow accumulation raster then allows you to identify the contributing area at each grid cell in the domain, a very useful quantity fundamental to much hydrologic analysis. Next an outlet point will be used to define a watershed as all points upstream of the outlet (step 4). Focusing on this watershed streams will be defined using a flow accumulation threshold within this watershed (step 5). Hydrology functions will be used to define separate links (stream segments) and the catchments that drain to them (steps 6 and 7). Next the streams will be converted into a vector representation (step 8) and more Hydrology toolbox functionality used to evaluate stream order (step 9) and the subwatersheds draining directly to each of the eight stream gauges in the example dataset (step 10). The result is quite a comprehensive set of information about the hydrology of this watershed, all derived from the DEM.

1. Fill
This function fills the sinks in a grid. If cells with higher elevation surround a cell, the water is trapped in that cell and cannot flow. The Fill function modifies the elevation value to eliminate these problems.

Select Spatial Analyst Tools → Hydrology → Fill. Set the input surface raster as dem and output surface raster as fil in Ex4_project.gdb.

Press Run. Upon successful completion of the process, the “fil” layer is added to the map.
Let's examine the impact of Fill on the DEM. Select **Spatial Analyst Tools  ➔ Map Algebra ➔ Raster Calculator** and evaluate `fil - dem`.

Select **Spatial Analyst Tools  ➔ Surface ➔ Contour**. Set the inputs as follows to determine 20 m contours of the original DEM, `dem`.
Symbolize the fil-dem and contour layers similar to:

Zoom in on the deepest Sink; you should see something similar to the image below.

This is Peter Sink. It is a real topographic feature, not an artifact, so it is a bit erroneous to fill it. Nevertheless for the sake of a complete watershed we fill it. The website http://twdef.usu.edu/Peter_Sinks/Sinks.html gives details on the record low temperatures that have been recorded here.
To turn in. A layout showing the deepest sink in the Logan River basin. Report the depth of the deepest sink as determined by fil-dem.

2. Flow Direction
This function computes the flow direction for a given grid. The values in the cells of the flow direction grid indicate the direction of the steepest descent from that cell.

Select Spatial Analyst Tools ➔ Hydrology ➔ Flow Direction.

Set the inputs as follows, with output "fdr" and "drp".

Press Run. Upon successful completion of the process, the flow direction grid "fdr" and percentage drop grid "drp" are added to the map.
To turn in: Make a screen capture of the attribute table of fdr and give an interpretation for the values in the Value field using a sketch.

3. Flow Accumulation
This function computes the flow accumulation grid that contains the accumulated number of cells upstream of a cell, for each cell in the input grid.

Select Spatial Analyst Tools → Hydrology → Flow Accumulation.

Set the inputs as follows. Note that I selected an Integer output type because we are not using a weight raster input and the result is a count (integer) of the number of upstream grid cells that drain into each grid cell.

Press Run.
Upon successful completion of the process, the flow accumulation grid “fac” is added to the map. This process may take **several minutes** for a large grid, so take a break while it runs!

Adjust the symbology of the Flow Accumulation layer "fac" to a classified scale with multiplicatively increasing breaks that you type in, to illustrate the increase of flow accumulation as one descends into the grid flow network. Use the “Classify” Button to enable you to select “Manual Interval” method and to type in your class breaks into the Upper value window in the Class breaks section.

After applying this layer symbology you may right click on the "fac" layer and **Save As Layer File**
The saved Layer File may be imported to retrieve the symbology definition and apply it to other data.

Pan and zoom to the outlet where the river leaves the watershed. Turn off unnecessary layers and arrange layer order so that you can see the Basin feature class on top of the fac layer. Use the identify tool to determine the value of “fac” at the point where the main stream exits the area defined by the Basin polygon. This location is indicated in the following figure.

The value obtained represents the drainage area in number of 30.92 x 30.92 m grid cells. Calculate the drainage area in km². Compare this drainage area to the drainage area reported by the USGS at the Logan River stream site (214 mi²) and to the area of the Basin feature class obtained from the online service watershed delineation.

To turn in: Report the drainage area of the Logan River basin in both number of 30.92 m grid cells and km² as estimated by flow accumulation. Report the area of the Logan River basin in km² as calculated by the arcgis.com watershed function. Report the area of the Logan River basin in km² as reported by the USGS for the Logan River stream site. Discuss reasons for any differences.
4. **Stream Definition**

Let's define streams based on a flow accumulation threshold within this watershed.

Select **Spatial Analyst Tools → Map Algebra → Raster Calculator** and enter the following expression, using the name *Str* for the output raster.

```
"fac" > 5000
```

The result is a raster representing the streams delineated over our watershed.
This extends across the buffer area at the downstream end. To ensure that our streams are within the watershed we want let's clip this. Locate the **Extract by Mask (Spatial Analyst)** tool and set the inputs as follows:

![Extract by Mask tool](image)

The result is a stream raster entirely within the Logan River Basin.
5. Stream Links
This function creates a grid of stream links (or segments) that have a unique identification. Either a link may be a head link, or it may be defined as a link between two junctions. All the cells in a particular link have the same grid code that is specific to that link.

Select **Spatial Analyst Tools → Hydrology → Stream Link**. Set the inputs as follows and click OK.

The result is a grid with unique values for each stream segment or link. Symbolize `strlink` with unique values so you can see how each link has a separate value.
6. **Catchments**

The Watershed function provides the capability to delineate catchments upstream of discrete links in the stream network.

Select **Spatial Analyst Tools → Hydrology → Watershed**. Set the inputs as follows. Notice that the Input raster or feature pour point data is the strlink grid. This results in the identification of catchments draining to each stream link. Click OK.

![Watershed tool parameters](image)

The result is a **catchment grid** where the grid cells in the area draining directly to each link are assigned a unique value the same as the link it drains to. This allows a relational association between lines in the strlink grid and area's in the catchment grid. Symbolize the catchment grid with unique values so you can see how each catchment has a separate value.
7. **Conversion to Vector**

Let's convert this raster representation of streams derived from the DEM to a vector representation.

Select **Spatial Analyst Tools → Hydrology → Stream to Feature**. Set the inputs as follows. Note that I named the output `drainageline` in the `Ex4_project.gdb\BaseMap` feature class.

Note here that we uncheck the Simplify polylines option. The simplification can cause streams to "cut corners" that can result in errors.

The result is a linear feature class "drainageline" that has a unique identifier associated with each link.

Select **Conversion Tools → From Raster → Raster to Polygon**. Set the inputs as follows again avoiding simplification of polygons.

The result is a Polygon Feature Class of the catchments draining to each link.

Due to the geometry of grid cells in catchment, you may get multiple polygons for a single catchment grid code value. Locate the **Dissolve (Data Management)** tool (in the geoprocessing toolbox) and set the following inputs.
This merges all polygons with the same gridcode value and results in a one to one association between DrainageLine features and CatchPolyDissolve features.

The feature classes drainageLine and catchpolydissolve represent the connectivity of flow in this watershed in vector form and will be used later for Network Analysis, enabled by having this data in vector form.
To turn in: Describe (with simple illustrations) the relationship between strlink, drainageline, catchment and catchpoly attribute and grid values. What is the unique identifier in each that allows them to be relationally associated?

To turn in. Prepare a layout showing the stream network and catchments delineated directly from the DEM.

To turn in. Report the total stream length, basin area and drainage density for the Logan River Basin as determined from the DEM delineated streams. Comment on the differences between this drainage density and the NHD/NHDPlus drainage densities.

OK. You are done!

Summary of Items to turn in.
1. The number of columns and rows, grid cell size, minimum and maximum elevation values in the Logan River Basin DEM
2. Prepare a layout showing the topography, Basin Outline, NHDPlusV2 streams, and Logan River Main stem stream for the Logan River Basin. Include a scale bar and North arrow and appropriate title, labeling and legend so that the map is self-describing.
3. Report the main stream length, total stream length, basin area and drainage density for the Logan River Basin as determined from NHDPlus flowlines. Report the total stream length and drainage density for the Logan River Basin as determined from NHD_HighRes flowlines. Comment on the differences. For each drainage density value calculate the average overland flow distance water originating on a hillslope has to travel before reaching a stream. Comment on the differences.
4. A layout showing the deepest sink in the Logan River basin. Report the depth of the deepest sink as determined by fil-dem.
5. Make a screen capture of the attribute table of fdr and give an interpretation for the values in the Value field using a sketch.
6. Report the drainage area of the Logan River basin in both number of 30.92 m grid cells and km² as estimated by flow accumulation. Report the area of the Logan River basin in km² as calculated by the arcgis.com watershed function. Report the area of the Logan River basin in km² as reported by the USGS for the Logan River stream site. Discuss reasons for any differences.
7. Describe (with simple illustrations) the relationship between StrLnk, DrainageLine, Catchment and CatchPoly attribute and grid values. What is the unique identifier in each that allows them to be relationally associated?
8. Prepare a layout showing the stream network and catchments delineated directly from the DEM.
9. Report the total stream length, basin area and drainage density for the Logan River Basin as determined from the DEM delineated streams. Comment on the differences between this drainage density and the NHD/NHDPlus drainage densities.
Network Analysis

Some of the real power of GIS comes through its use for Network Analysis. A Network is an ArcGIS data structure that facilitates the identification of upstream and downstream connectivity.

However the form of network most suited to analysis of river networks is a utility network, and utility network functionality has not yet been added to ArcGIS Pro. See: http://pro.arcgis.com/en/pro-app/help/analysis/networks/what-is-network-analyst-.htm.

If you would like to learn about network analysis you will need to use ArcGIS Desktop (Any 10.x version should work. The latest is version 10.5). The 2015 version of this exercise http://hydrology.usu.edu/dtarb/giswr/2015/Ex42015.pdf starting on page 43 provides an introduction to Network Analysis for you to explore if interested.